Converting MicroSim® Schematics Designs to Orcad Capture® Designs

Quick Start
# Contents

Before you begin v
Welcome ........................................ v
How to use this guide ................................ vi
  Symbols and conventions ................................ vi
  Related documentation ................................ vii

Chapter 1  Translating designs  9
Overview ........................................ 9
About the translator ................................ 10
Starting the Translator ............................ 11
Translating designs ............................... 12
  Translating from within Capture ................... 12
    Warning messages ................................ 12
  Translating stand-alone ............................ 15
What you may see in your translated design .......... 17
What does not translate ............................ 20

Chapter 2  Getting started in Capture  21
Overview ........................................ 21
What you gain by moving to Capture .................. 22
  Design management features ......................... 22
  Editing capabilities ................................. 23
  Learning aids ...................................... 23
Tips for working in Capture ........................ 24
  Project and design management ....................... 24
  The project manager window ......................... 25
  Ground Symbols .................................. 25
  Ports ............................................... 26
  Viewing messages .................................. 26
  Configuring libraries .............................. 26
Contents

- Placing and drawing items ............................................. 27
- Labeling wires ......................................................... 28
- Selecting and moving items ........................................... 28
- Editing parts ............................................................ 29
  - How symbols are associated with package definitions .......... 30
- Hierarchy blocks ....................................................... 30

Appendix A  Command reference  31
- Overview ................................................................. 31
- Commands ............................................................... 32

Appendix B  Terminology reference  35
- Overview ................................................................. 35
- Terminology ............................................................ 36

Appendix C  Translator mapping file  37
- Overview ................................................................. 37
- What is the translator mapping file? ................................. 38
- What is in the file? ..................................................... 38
- Using the file ............................................................ 39
  - Formatting records .................................................. 39
  - Comment lines ....................................................... 39
  - Writing a scope record .............................................. 39
    - Global scope ...................................................... 40
    - Global library scope ............................................ 40
    - Global part scope ............................................... 40
    - Specific part scope ............................................. 40
  - Writing a rule record ................................................ 41
    - Manipulator field ................................................ 41
    - Original name field ............................................. 41
    - New name field .................................................. 41

Index  43
Before you begin

Welcome

Orcad family products offer a total solution for your core design tasks: schematic- and VHDL-based design entry; FPGA and CPLD design synthesis; digital, analog, and mixed-signal simulation; and printed circuit board layout. What's more, Orcad family products are a suite of applications built around an engineer's design flow—not just a collection of independently developed point tools. The Schematics-to-Capture translator is just one element in our total solution design flow.

The Schematics-to-Capture translator converts MicroSim schematics, symbol libraries, and package libraries to Orcad Capture Release 9 designs and libraries. You can translate designs generated in MicroSim Schematics versions 5.4 to 8.0.
How to use this guide

This guide is designed so you can quickly find the information you need to use the Schematics-to-Capture translator. To help you learn and use the Schematics-to-Capture translator efficiently, this manual is separated into the following sections:

• Translating designs
• Getting started in Capture

Symbols and conventions

Our printed documentation uses a few special symbols and conventions.

<table>
<thead>
<tr>
<th>Notation</th>
<th>Examples</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>(\text{Ctrl}+\text{R})</td>
<td>Press (\text{Ctrl}+\text{R}).</td>
<td>Means to hold down the (\text{Ctrl}) key while pressing (\text{R}).</td>
</tr>
<tr>
<td>(\text{Alt}, \text{F}, \text{O})</td>
<td>From the File menu, choose Open ((\text{Alt}, \text{F}, \text{O})).</td>
<td>Means that you have two options. You can use the mouse to choose the Open command from the File menu, or you can press each of the keys in parentheses in order: first (\text{Alt}), then (\text{F}), then (\text{O}).</td>
</tr>
<tr>
<td>Monospace font</td>
<td>In the Part Name text box, type \text{PARAM}.</td>
<td>Text that you type is shown in monospace font. In the example, you type the characters \text{P}, \text{A}, \text{R}, \text{A}, and \text{M}.</td>
</tr>
<tr>
<td>UPPERCASE</td>
<td>In Capture, open CLIPPERA.DSN.</td>
<td>Path and filenames are shown in uppercase. In the example, you open the design file named CLIPPERA.DSN.</td>
</tr>
<tr>
<td>Italic</td>
<td>In Capture, save \text{design name}.DSN.</td>
<td>Information that you are to provide is shown in italics. In the example, you save the design with a name of your choice, but it must have an extension of .DSN.</td>
</tr>
</tbody>
</table>
Related documentation

In addition to this guide, you can find technical product information in the online help, and our technical web site, as well as in other books. The table below describes the types of technical documentation provided with the Schematics-to-Capture translator.

<table>
<thead>
<tr>
<th>This documentation component . . .</th>
<th>Provides this . . .</th>
</tr>
</thead>
<tbody>
<tr>
<td>This online guide—&lt;br&gt;Converting MicroSim Schematics Designs to Orcad Capture Designs Quick Start</td>
<td>A comprehensive guide for understanding and using the features available in the Schematics-to-Capture translator.</td>
</tr>
<tr>
<td>Online help</td>
<td>Comprehensive information for understanding and using the features available in the Schematics-to-Capture translator. You can access help from the Help menu in the Schematics-to-Capture translator, by choosing the Help button in a dialog box, or by pressing [F1]. Topics include:</td>
</tr>
<tr>
<td></td>
<td>• Explanations and instructions for common tasks.</td>
</tr>
<tr>
<td></td>
<td>• Descriptions of menu commands, dialog boxes, tools on the toolbar and tool palettes, and the status bar.</td>
</tr>
<tr>
<td></td>
<td>• Error messages and glossary terms.</td>
</tr>
<tr>
<td></td>
<td>• Reference information.</td>
</tr>
<tr>
<td></td>
<td>• Product support information. You can get context-sensitive help for a error message by placing your cursor in the error message line in the session log and pressing [F1].</td>
</tr>
</tbody>
</table>

How to use this guide
### Before you begin

<table>
<thead>
<tr>
<th>This documentation component . . .</th>
<th>Provides this . . .</th>
</tr>
</thead>
<tbody>
<tr>
<td>Orcad family customer support at <a href="http://www.orcad.com/technical/technical.asp">www.orcad.com/technical/technical.asp</a></td>
<td>An Internet-based support service available to customers with current support options. A few of the technical solutions within the customer support area are:</td>
</tr>
<tr>
<td></td>
<td>• The Knowledge Base, which is a searchable database containing thousands of articles on topics ranging from schematic design entry and VHDL-based PLD design to PCB layout methodologies. It also contains answers to frequently asked questions.</td>
</tr>
<tr>
<td></td>
<td>• The Knowledge Exchange, which enables you to share information and ideas with other users and with our technical experts in a real-time online forum. You can submit issues or questions for open discussion, search the Knowledge Exchange for information, or send email to another participant for one-on-one communication. A list of new postings will appear each time you visit the Knowledge Exchange, providing you with a quick update of what's been discussed since your last visit.</td>
</tr>
<tr>
<td></td>
<td>• The Technical Library, which contains online customer support information that you can search through by category or product. You can find product manuals, product literature, technical notes, articles, samples, books, and other technical information. Additionally, technical information can be obtained through SourceLink, which is an online customer support information service for users of Cadence software other than Capture, Component Information System (CIS), Express, Layout, or PSpice.</td>
</tr>
<tr>
<td></td>
<td>• The Support Connection, which allows you to choose to either view and update existing incidents, or create new incidents. The information is delivered directly to us via our internal database. This service is only available to customers with current maintenance or Extended Support Options (ESOs) in the United States and Canada.</td>
</tr>
<tr>
<td></td>
<td>• The Live Connection, which enables you to open access to your computer to a Customer Support person, who can then view your actions on your computer monitor as you demonstrate the problem you’re having. Live Connection’s two-way transmission can also let you view the actions on the Customer Support person’s computer monitor, as he or she demonstrates a method or procedure to help you solve your problem. To participate in Live Connection, you need to contact a Customer Support person, in order to obtain a support number to grant you access to the Live Connection site, and to set up a time to “meet online” using Live Connection.</td>
</tr>
</tbody>
</table>
Overview

This chapter explains how to set up and use the Schematics-to-Capture translator to migrate designs created with MicroSim Schematics to Orcad Capture Release 9.

The following sections are included:

- About the translator on page 1-10
- Starting the Translator on page 1-11
- What you may see in your translated design on page 1-17
- What does not translate on page 1-20
About the translator

The Schematics-to-Capture translator converts MicroSim schematics, symbol libraries, and package libraries to Capture Release 9 designs and libraries. You can translate designs generated in MicroSim Schematics from versions 5.4 to 8.0.

Note Wherever possible, the connectivity of the original schematic is maintained, and the “look” of the translated schematics and symbols is the same as the “look” of the originals. Where this is not possible, warning messages are displayed and the resulting design will require some editing.

Capture combines package information with symbol definitions. For this reason, symbol libraries and package libraries are translated together; they cannot be translated separately. If a symbol library does not have a corresponding package library, then the translator generates default packages using the symbols’ pin numbers.
Starting the Translator

The translator is started within Capture.

To start the translator

1. From the File menu, choose Import Design. The Import Design dialog box appears.
Translating designs

The symbols used in MicroSim Schematics are translated along with the design file; therefore, your MicroSim symbol libraries must be installed. Also, the MSIM.INI (configuration) file must be installed.

Translating from within Capture

Use the translator from within Capture when you want to translate a single schematic and have it immediately ready for editing.

Warning messages

Wherever possible, the electrical connectivity and the “look” of the translated schematic pages (and symbols) are the same as the originals. Where this is not possible, warning messages are displayed in the Capture Session Log that tell you which items need to be edited. For descriptions of the items that may need editing, see What you may see in your translated design on page 1-17.

To translate a single- or multi-page design

1. From the File menu, choose Import Design. The Import Design dialog box appears.
2. Click the PSpice tab.
3. In the Open text box, enter the path for the original Schematics design file, or use the Browse button to find the file.
4. In the Save As text box, enter the directory where you want to save the translated design, or use the Browse button to specify a path. The default location is the directory of the original Schematics file. The default name is the same as the original Schematics file name with an .OPJ extension.
5  In the MSIM.INI file text box, enter the location of MSIM.INI, if it is not already shown. This is normally found in the Windows directory.

6  Click OK.

The translated schematic appears in the Capture schematic page editor and is ready for editing.

To translate a design with hierarchical blocks

1  From the File menu, choose Import Design.

The Import Design dialog box appears.

2  Click the PSpice tab.

3  In the Open text box, enter the path for the original Schematics design file that contains a hierarchy, or use the Browse button to find the file.

4  In the Save As text box, enter the directory where you want to save the translated design, or use the Browse button to specify a path. The default location is the directory of the original Schematics file. The default name is the same as the original Schematics file name with an .OPJ extension.

5  In the MSIM.INI file text box, enter the location of MSIM.INI, if it is not already shown. This is normally found in the Windows directory.

6  Select the Translate Hierarchy checkbox.

7  Select the Consolidate all Schematic files into one Design file checkbox.

8  Click OK.

The Project Manager appears.

All the schematics referenced in that design are listed.

Note  If the design uses multiple views, the default implementation given to hierarchical blocks is the implementation for PSpice.

All sub-schematics for hierarchical blocks are translated as well and they are consolidated into the single design file.

See Multiple Views on page 1-19.
Chapter 1  Translating designs

To translate a symbol library

1. From the File menu, choose Import Design.
   The Import Design dialog box appears.
2. Click the PSpice tab.
3. In the Open text box, enter the path for the MicroSim symbol library (*.SLB), or use the Browse button to find the file.
4. In the Save As text box, enter the directory where you want to save the translated library, or use the Browse button to specify a path. The default location is the directory of the original library. The default name is the same as the original Schematics file name with an .OPJ extension.
5. Change the filename extension from .OPJ to .OLB.
6. In the MSIM.INI file text box, enter the location of MSIM.INI, if it is not already shown. This is normally found in the Windows directory.
7. Click OK.

An Orcad part library (*.OLB) is created, and the Capture project manager appears. When the project manager window is maximized, the Capture title bar says:

Orcad Capture for Windows - [library name]

To translate a symbol library with hierarchy

1. From the File menu, choose Import Design.
   The Import Design dialog box appears.
2. Click the PSpice tab.
3. In the Open text box, enter the path for the MicroSim symbol library (*.SLB) that contains hierarchical symbols, or use the Browse button to find the file.

For each symbol:

- If there is a package library, then the pin numbers will come from the package. When there are multiple gates, you can choose View Package and see multiple packages.
- If there is no package library then the pin numbers will come from the symbol.

Note: If the symbol library you are translating has the same name as a previously existing Orcad part library in the same directory, the translator overwrites the old library with the new one. To keep the old library, specify a different directory for the new library in the Save As dialog box.
4  In the Save As text box, enter the directory where you
want to save the translated library and design, or use
the Browse button to specify a path. The default
location is the directory of the original schematic. The
default name is the same as the original Schematics file
name with an .OPJ extension.

5  In the MSIM.INI file text box, enter the location of
MSIM.INI, if it is not already shown. This is normally
found in the Windows directory.

6  Select the Translate Hierarchy checkbox.

7  Select the Consolidate all Schematic files into one
Design file checkbox.

8  Click OK.

A Capture library (*.OLB) is created, and the Capture
project manager appears.

Translating stand-alone

Use the stand-alone translator when you simply want to
translate a set of designs or symbol libraries, without
opening all the converted files immediately in Capture.
To translate in stand-alone mode

1. From the Start menu, choose Run.
2. Enter the path and filename for SCH2CAP.EXE and click OK.
   The Import Design dialog box appears.
3. In the Open text box, click Browse.
   Select the file (or range of files) you want to translate, then click OK.
4. In the Save As text box, enter the directory where you want to save the translated designs. The default location is the directory of the original Schematics file(s), or use the Browse button to specify a path.
5. In the MSIM.INI text box, enter the location of MSIM.INI, if it is not already shown. This is normally in the Windows directory.
6. Check Translate All Subschematics to translate all the subschematics in addition to the top-level schematics of a hierarchical design.
7. Check Consolidate all files to merge the schematic and library files together into one design.
8. Click OK.
What you may see in your translated design

Following are new items or changes you may see in your translated design. Some issues listed below require you to take some action, while the translator automatically takes the action for others. In either case, a warning is issued, keeping you informed of the situation.

**Bus labels and bundles**  Busses labeled with only one signal (for example, Bus1) are translated as wires.

Busses can only carry a contiguous sequence of signals with the same name, such as A[0-4]. Because of this, bus bundles and bundled pin names, such as A[0-1],B[0-1] or A,B,C, do not translate. You need to rename these busses in Capture.

Busses labeled with comma separators change to hyphenated sequences (for example, A[0,1,2] becomes A[0-2] and A0,A1,A2 becomes A[0-2]).

Bus labels that end in numbers (for example, Bus13[0-7]) will not be translated because these are not supported by Capture. You need to rename these busses to end in a non-numeric value.

**Text**  If the text in your original schematic used fonts that were not TrueType, that text will appear in the translated design using the default font (Arial). If you want to add more text, you need to use a TrueType font.

Text justification may be altered in the translated design because Capture does not support justification.

Annotation text boxes in the resulting schematic may have lines that wrap. MicroSim Schematics truncated words outside the text box, while Orcad Capture wraps the word to the next line.
Connectivity via wire labels

Connectivity via wire labels works within a schematic page, but not across schematic pages; for example, a wire labeled CLK on schematic page one is not connected to CLK on schematic page two.

To maintain connectivity where the original schematic used wire labels across schematic pages, the translator adds small off-page connectors to wires.

Pin names and numbers

In Capture, you can either display all the pin names or display none. Pin names and numbers are displayed as text next to the respective pins. All pin name text is made the same point size in the translated design.

Port pins do not have names or numbers, so any names and numbers assigned to port pins in the original design are not present in the translated design.

Pin names and number positions are automatically set by Capture, relative to the pin. If pins are placed on the corners of a symbol, then the pin number orientation may be different in the translated design from the original schematic.

Translated symbol libraries may have overlapping pin names. You can correct this in the translated design by setting the font size in your schematic to be different from that of the originating symbol library.

Graphics

Symbols use only one color. If the symbols in your original schematic used multiple colors, they are one color in the translated design.

Custom colors defined in the original schematic are mapped to the closest colors available.

Xilinx and PLSyn

Designs containing symbols for Xilinx parts or symbols created using MicroSim PLSyn will translate to Capture but they will not simulate. You can delete the Xilinx or PLSyn parts and reuse the remainder of the circuit for other designs in Capture.
Symbols and parts  Stimulus, current probe, initial condition, node set and PSpice command symbols all translate into parts in Capture. Annotation symbols translate into title block symbols.

Heterogeneous parts (those made up of different type gates within one package) translate into one part in Capture that has multiple gates.

AKO parts  The translator duplicates attribute graphics, pins and other aspects of symbols for each instance of an AKO part.

Attributes  In Capture, attributes are called properties. Pin and property names are case-sensitive. In other words, the property “VALUE” is distinct from the property “Value”. Therefore, the following property names change as shown during translation:

<table>
<thead>
<tr>
<th>Attribute before...</th>
<th>Property after...</th>
</tr>
</thead>
<tbody>
<tr>
<td>TEMPLATE</td>
<td>PSpiceTemplate</td>
</tr>
<tr>
<td>VALUE</td>
<td>Value</td>
</tr>
</tbody>
</table>

The IPIN attribute, when translated, makes hidden pins visible in Capture. A small global port is added to these.

Multiple Views  If a hierarchical block or symbol contained multiple views in Schematics, all subschematics referenced are translated. However, the hierarchical block or symbol is translated to refer to the subschematic referenced by the PSpice view. You can change the hierarchical block’s or symbol’s subschematic by editing the block or part in Capture and changing its implementation.
To change implementations of hierarchical blocks

1. Double-click the hierarchical block and change the Implementation name to the name of a schematic in the hierarchy. See attaching implementation on page B-36 for more information.

2. Repeat for each hierarchical block.

Variable-width pin symbol

If you translate a symbol library with symbols that contain variable-width pins, you will need to create parts with fixed-width pins. For example, instead of the FSTIM symbol, create FSTIM16 or FSTIM32.

For schematics that contain variable-width pin symbols, the translator creates fixed-width versions and places them in the design’s design cache.

Footprint mapping file

The mapping file (S2CFPMAP.TXT) is a text file you can use to control how the translator maps footprint names from the Schematics naming convention to the convention used in Orcad Layout. You can add your custom footprint names and set how they are renamed for use in your translated design.

What does not translate

The following design objects do not translate from Schematics to Capture:

- custom borders
- no connect symbols
- viewpoints
Getting started in Capture

Overview

This chapter introduces Orcad Capture to users familiar with MicroSim Schematics. It contains the following sections to help you quickly get started using Capture:

- What you gain by moving to Capture on page 2-22
- Tips for working in Capture on page 2-24
What you gain by moving to Capture

Design management features

- Design cache, which makes designs self-contained, not affected by library changes (see design cache on page B-36)
- Project manager
  - Hierarchical browser
  - Hierarchical printing
  - Hierarchical find
- Library configurations are saved per design
- Settings—such as options and preferences—can be saved per design
- EDIF import and export capability
- PDIF import capability
- Many netlist formats, including the option to write your own netlist format
- Ability to add custom utilities to the Accessories menu
- Cross-reference report of parts, including an unused gates report and a report of which libraries parts originate from
Editing capabilities

- Print preview
- True ERC capability with DRC markers
- Bookmarks
- Macro capabilities
- Right mouse button context menus
- Go To command (on the View menu) for moving to a location based on X-Y coordinates, grid location, or bookmarks
- Spreadsheet control for editing multiple objects to update properties, like package type, globally
- Ability to edit multiple parts simultaneously
- Copy by dragging an object (press and hold [Ctrl] key at the same time as you move the object)
- Group and Ungroup commands to group objects
- Grid lines in addition to grid dots
- Area selection and cycling through the selection
- Bus rippers
- Interactive creation of wire junctions
- Dynamic scrolling
- Improved no-connect handling (a property set for a pin, where if you move the part, the no-connect follows)
- Unconnected pin feedback (in the form of a square drawn around the pin’s hotspot)
- Lines in addition to polylines
- Ellipses
- Pattern support for filled graphics

Learning aids

- Online tutorial in addition to Help
Chapter 2  Getting started in Capture

Tips for working in Capture

Project and design management

In Capture, schematics are stored in design (.DSN) files. A .DSN file can contain all schematics associated with a design. Each schematic can have one or more pages.

Capture also creates project files (.OPJ). They contain, among other things:

- The type of the project.
- A reference to the design file (.DSN) that contains the schematics associated with the project.
- References to the analysis set-up information.
- Project specific settings, such as whether the project is to be simulated with PSpice.
- List of design-specific model, include, and stimulus libraries for PSpice.

When starting new circuits, or editing existing ones, always use the New Project and Open Project commands.

If you want to simulate designs with PSpice, it is critical that you work with project files rather than with design files. If you open the .DSN files directly for editing, you will not see the PSpice menu in Capture.

Note  For designs that you want to simulate with PSpice, it is essential that you work with project files rather than with design files.
The project manager window

When you create or open an existing project, a project manager window is opened in Capture. When the project manager window is active, the set of menu commands that are available change. You can:

- View the schematics and pages in your design.
- View the set of analysis setups for your project.
- View the hierarchical structure of your design.
- Save and archive the project.
- Change DRC settings.
- Create PSpice subcircuits.
- Create additional schematic pages.
- Create additional schematics.
- Copy schematics and pages from one project into another project.
- Delete schematics and pages.
- Create different types of netlists.
- Annotate reference designators.

To switch to the project manager window while in Capture, use the Windows Menu.

Ground Symbols

To place an analog ground symbol in Capture, choose the Ground command from the Place menu. You can either use the ‘0’ ground symbol or use one of the other ground symbols. However, if you use a symbol other than ‘0’, you will need to rename the symbol (by double-clicking) to ‘0’ for PSpice to simulate.
Ports

In MicroSim Schematics, ports were placed by choosing the Part command from the Place menu, and choosing symbols from the PORT.SLB library. In Capture, there are specific commands for placing ports. Choose the Hierarchical Port and Off-Page port commands from the Place menu.

Global ports (such as the bubble port in Schematics) are not supported. You can choose the Power command from the Place menu to place global power ports and rename them as necessary.

Viewing messages

The Capture session log is a window within Capture where messages and errors appear. This is similar to the Schematics Message Viewer.

Use the Session Log command in the Window menu to show the session log.

Configuring libraries

When you first create a new design, there are no libraries configured. You can place parts from the design cache or from any configured libraries. See Placing, editing and connecting parts and electrical symbols in the Orcad Capture User’s Guide for more detailed information on configuring libraries.

For PSpice projects, use only part libraries that have been set up for referencing PSpice models. These are installed in the PSpice folder in Capture\Library.
Placing and drawing items

Capture has individual menu commands for placing ports, power and ground symbols, off-page connectors, and parts. In Schematics all of these different parts were listed in the Part Browser.

To place a ground, click the Ground button on the toolbar to provide a filtered list of symbols you can use.

When drawing a wire, click the Draw Wire button to enter drawing mode, then click to start the wire and place vertices. When you have finished, click the right mouse button to display the a pop-up menu, and select End Wire to end drawing mode.

Connectivity via wire labels works within a page, but not across pages; for example, a wire labeled CLK on page one is not connected to CLK on page two. To connect across pages, use off-page connectors. See Connectivity via wire labels on page 1-18.

Although there is a Place Junction command, junctions are created automatically when you draw a wire, if you end the wire on a wire, another wire’s endpoint, or on a part’s pin. However, placing a pin in the middle of a wire does not make a connection.

Placed text does not have Fill or Outline Box capabilities. You can insert bitmaps (but not metafiles).

If a pin’s hotspot is unconnected, a small square is drawn around it.

Rotating a part in Capture rotates it in place, whereas in Schematics it rotated around the origin.

Mirroring a part in Capture flips a part along either the horizontal or vertical axis, whereas in Schematics it only flipped along the vertical axis.
Chapter 2    Getting started in Capture

Labeling wires

After drawing the wire, place a net alias. Click the Label Wire button, type in the net alias, press OK, then click on the wire to attach the alias. The display of the net alias on the wire labels that wire. In Capture, the net alias must be placed so that the lower, left corner touches the wire or bus.

Selecting and moving items

In Capture, you select by clicking on a wire or part. When clicking on a part, you may sometimes select a pin rather than the part itself (Capture lets you select pins for setting instance-specific pin properties). To select the part instead, you can press and hold the tab key and click again to get the part. Pressing tab while clicking selects the next item that is selectable at that point. As with Schematics, you can also select an item by dragging a box around it. Capture lets you define whether items get selected by being entirely within the area. See Defining your preferences in Chapter 4, in the Orcad Capture User’s Guide.

Press Ctrl to extend your selection (instead of Shift in Schematics).

Also, in Capture, after selecting an item or area, pressing Ctrl while dragging copies the selection and pastes.

You can use the Group and Ungroup commands on the Edit menu to group and ungroup objects. The Group command is not available if you have any net aliases in the set of selected objects.

Zoom All includes the title block, so it is equivalent to viewing the Entire Page in Schematics. If you turn off display of the title block, Zoom All is equivalent to View Fit in Schematics.

For example, if you want to select a wire that is under a symbol and not the symbol itself, press Tab while selecting.
Tips for working in Capture

To turn off display of the title block
1. From the Options menu, choose Schematic Page Properties.
2. Click the Grid Reference tab.
3. In the Title Block Visible group box, clear the Displayed check box.

Editing parts

In Capture, you have a choice of assigning reference designators as you place parts, or after the parts are placed. You make this choice with the Preferences command on the Options menu. If you don’t enable the Auto Reference placed parts option, reference designators are not assigned as you place parts. However, they are assigned automatically when you annotate the schematic.

A No Connect is a pin property (not a separate symbol) that stays with the part when the part is moved.

To edit a part (symbol)
1. Select a part on the schematic.
2. From the Edit menu, choose Part.
   The Capture part editor appears, with the symbol that is stored in the Design Cache ready to edit.

To change a reference
1. Double-click the reference designator. The Display Properties dialog box appears.
2. Edit the value, and if needed, the display format.
3. Click OK.

To annotate the schematic, in the project manager, select the design. From the Tools menu, choose Annotate.

Note No libraries are configured when the schematic is first translated. Before you configure a library, you can only place parts stored in the design cache. See design cache on page B-36 for more information.
How symbols are associated with package definitions

In Schematics, when a component was available in multiple package types, a single symbol was created. The package definition associated with the symbol contained a list of the package types and the pin numbering used for each package type. In Capture, separate parts are created for each package type that has different pin numbers.

When translating designs, a part for the package type used in the schematic is created. If the same part is used elsewhere on the schematic with a different package type, then a separate graphic representation is created.

By default, a single part is created for each symbol from the Schematics library. If there are multiple package types associated with a part, the first package type listed is used. This means the pin numbers on the part are those of the first package type, and the package type name is added as a property of the part.

Hierarchy blocks

To push into a hierarchical block:

1. Select the hierarchical block and click the right mouse button
2. From the pop-up menu, choose Descend Hierarchy. You can also choose Descend Hierarchy from the View menu.

Shortcut: (Ctrl)+D

To place pins, select the block, then from the Place menu, choose Hierarchical Pin.

Note that the Implementation Name is the schematic folder name.

Hierarchical blocks don’t automatically create pins when you attach wires. You need to place them manually.

When creating blocks, you can reference a schematic either in the same design (by leaving the Path text box blank) or in a different design (by entering the path and name of the other design in the Path text box).
Command reference

Overview

This appendix provides a reference for the menu commands used in Schematics and their equivalent Capture 9 commands.

It contains the following section:

- Commands on page A-32

See the Orcad Capture User's Guide and Capture's online help for more information on how to use these or any other commands.
## Commands

<table>
<thead>
<tr>
<th>This Schematics command...</th>
<th>Is similar to this Capture command...</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>File menu</strong></td>
<td></td>
</tr>
<tr>
<td>New</td>
<td>New Project, New Library</td>
</tr>
<tr>
<td>Export</td>
<td>Export to DXF</td>
</tr>
<tr>
<td><strong>Edit menu</strong></td>
<td></td>
</tr>
<tr>
<td>Undo</td>
<td>Undo</td>
</tr>
<tr>
<td>Redo</td>
<td>Redo</td>
</tr>
<tr>
<td>Repeat</td>
<td>Repeat</td>
</tr>
<tr>
<td>Cut</td>
<td>Cut</td>
</tr>
<tr>
<td>Copy</td>
<td>Copy</td>
</tr>
<tr>
<td>Paste</td>
<td>Paste</td>
</tr>
<tr>
<td>Delete</td>
<td>Delete</td>
</tr>
<tr>
<td>Select All</td>
<td>Select All</td>
</tr>
<tr>
<td>Attributes</td>
<td>Properties</td>
</tr>
<tr>
<td>Symbol</td>
<td>Part</td>
</tr>
<tr>
<td>Flip</td>
<td>Mirror</td>
</tr>
<tr>
<td>Rotate</td>
<td>Rotate</td>
</tr>
<tr>
<td>Find</td>
<td>Find</td>
</tr>
<tr>
<td><strong>Draw menu</strong></td>
<td></td>
</tr>
<tr>
<td>Get New Part</td>
<td>Part, Off-Page Connector, Hierarchical Port, No Connect, Title Block, Power, Ground (on the Place menu)</td>
</tr>
<tr>
<td>Wire</td>
<td>Wire (on the Place menu)</td>
</tr>
<tr>
<td>double-clicking a wire</td>
<td>Net Alias (on the Place menu)</td>
</tr>
<tr>
<td>Bus</td>
<td>Bus Entry (on the Place menu)</td>
</tr>
</tbody>
</table>

Other File menu commands in Capture:
- Export Selection
- Import Selection
- Print Preview

Other Edit menu commands in Capture:
- Group
- Ungroup

Other Place menu commands in Capture:
- Junction
- Bus Entry
- Bookmark
### Commands

<table>
<thead>
<tr>
<th>This Schematics command...</th>
<th>Is similar to this Capture command...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Block Block</td>
<td>Hierarchical Block (on the Place menu)</td>
</tr>
<tr>
<td>drawing a wire to the edge of a block</td>
<td>Hierarchical Pin (on the Place menu)</td>
</tr>
<tr>
<td>Box Box</td>
<td>Rectangle</td>
</tr>
<tr>
<td>Circle Circle</td>
<td>Ellipse</td>
</tr>
<tr>
<td>Arc Arc</td>
<td>Arc</td>
</tr>
<tr>
<td>Polyline Polyline</td>
<td>Line, Polyl ine</td>
</tr>
<tr>
<td>Insert Picture Insert Picture</td>
<td>Text (on the Place menu)</td>
</tr>
<tr>
<td>Text Text</td>
<td></td>
</tr>
</tbody>
</table>

#### Navigate menu

<table>
<thead>
<tr>
<th>Pop, Top Pop, Top</th>
<th>Ascend Hierarchy (on the View menu)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Push Push</td>
<td>Descend Hierarchy (on the View menu)</td>
</tr>
<tr>
<td>Select Page Select Page</td>
<td>Go To (on the View menu)</td>
</tr>
</tbody>
</table>

#### View menu

<table>
<thead>
<tr>
<th>Fit Fit</th>
<th>Zoom All (if the title block is not displayed)</th>
</tr>
</thead>
<tbody>
<tr>
<td>In In</td>
<td>Zoom In</td>
</tr>
<tr>
<td>Out Out</td>
<td>Zoom Out</td>
</tr>
<tr>
<td>Area Area</td>
<td>Zoom Area</td>
</tr>
<tr>
<td>Entire Page Entire Page</td>
<td>Zoom All (if the title block is displayed)</td>
</tr>
<tr>
<td>Redraw Redraw</td>
<td>Redraw</td>
</tr>
<tr>
<td>Pan–New Center Pan–New Center</td>
<td>Zoom Selection</td>
</tr>
<tr>
<td>Toolbars Toolbars</td>
<td>Toolbar, Tool Palette</td>
</tr>
<tr>
<td>Status Bar Status Bar</td>
<td>Status Bar</td>
</tr>
</tbody>
</table>

#### Options menu

<table>
<thead>
<tr>
<th>Pan and Zoom Pan and Zoom</th>
<th>Preferences</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display Options Display Options</td>
<td>Preferences</td>
</tr>
</tbody>
</table>

Other View menu commands in Capture:

- Scale
- Grid
- Grid References

The Preferences dialog box in Capture defines settings in your Capture environment.

The Design Template dialog box defines settings in all new designs.

The Schematic Page Properties dialog box defines settings for the current schematic page only.
### This Schematics command... | Is similar to this Capture command...
---|---
Display Preferences | Preferences, Design Template
Editor Configuration | Schematic Page Properties

### Window menu
- New
- Tile Horizontal
- Tile Vertical

### Help menu
- Keyboard Shortcuts
- Library List
- Schematics User’s Guide
- Technical Support

---

**Other Help menu commands in Capture:**
- Processes
- How to Use Help
- Help for SDT Users

---

This Schematics command... Is similar to this Capture command...
Overview

This appendix introduces terms and concepts specific to Capture and relates them to any similar Schematics terms and concepts.
<table>
<thead>
<tr>
<th>Terminology</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>attaching implementation</td>
<td>Equivalent in MicroSim terminology to pushing into a hierarchical block for the first time and naming the schematic. Each hierarchical block can have only one implementation associated with it at a time.</td>
</tr>
<tr>
<td>design</td>
<td>A design file (.DSN) contains one or more schematics and a design cache.</td>
</tr>
<tr>
<td>design cache</td>
<td>Copies of each part used in a design are stored in a design cache. When you first open a schematic, no libraries are configured, but you can place parts stored in the cache. One advantage of using a design cache is that you can change a part in a library without affecting the schematic, and vice versa. This makes the design self-contained and easily archived.</td>
</tr>
<tr>
<td>footprint</td>
<td>Equivalent in MicroSim terminology to a package type.</td>
</tr>
<tr>
<td>part</td>
<td>Equivalent in MicroSim terminology to a symbol with packaging information.</td>
</tr>
<tr>
<td>part in a package</td>
<td>Equivalent in MicroSim terminology to a gate.</td>
</tr>
<tr>
<td>project</td>
<td>A project file (.OPJ) is associated with one design and contains references to the resources used in the design, such as libraries, netlists, bills of materials reports, and fuse maps.</td>
</tr>
<tr>
<td>schematic folder</td>
<td>A collection of all schematic pages at the same level of hierarchy in a design.</td>
</tr>
<tr>
<td>schematic page</td>
<td>The page on which a design is drawn.</td>
</tr>
</tbody>
</table>
Overview

This appendix explains how to use the translator mapping file to control the way that the translator manipulates attributes and footprint names.

It contains the following sections:

- [What is the translator mapping file? on page C-38](#)
- [What is in the file? on page C-38](#)
- [Using the file on page C-39](#)
What is the translator mapping file?

The mapping file is a text file you can use to control how the translator manipulates attributes and footprint names.

What is in the file?

The file contains a scope record followed by rule records.

The scope record  Tells the translator which libraries and parts to apply the rules to. A scope record must precede any rule records.

The rule records  Define the rules for what the translator should do for the attributes and footprints of the libraries and parts contained in the scope.
Using the file

Formatting records

A record is a line of text made of fields (words or names) separated by a space or tab. The fields must follow the order given for the type of record.

All records are case-insensitive, meaning that uppercase and lowercase letters are treated the same.

Comment lines

An asterisk in the first column is considered a comment (just as in model definitions). A comment line can appear anywhere in the file. For example:

* This is a comment line
* Another comment line

The translator ignores comment text.

Writing a scope record

A scope record specifies which libraries and parts the translator applies the rules to. A scope record contains a parameter followed by a value. There are four types of scope records you can use:

- Global
- Global library
- Global part
- Specific part
**Global scope**

A global scope applies to all symbols in all libraries. For example:

```
[* *]
```

This will apply the rules to all the symbols in all the libraries.

**Global library scope**

A global library scope applies either to one specific library or to all libraries of the same name. For example:

```
[Port *]
```

This will apply the rules to all parts within any PORT.SLB.

```
["d:\msim_8\lib\port.slb" *]
```

This will apply the rules to all parts within this specific PORT.SLB file.

Long file names must be within double quotes.

**Global part scope**

A global part scope applies to all parts of the same name contained in all the libraries. For example:

```
[* agnd]
```

This will apply the rules to all parts named agnd in all the libraries.

**Specific part scope**

A specific part scope applies either to a specific part within a specific library or to a specific part in all libraries of the same name. For example:

```
[Port agnd]
```

This applies the rules to only agnd within any PORT.SLB.

```
["d:\msim_8\lib\port.slb" agnd]
```

This applies the rules to only part agnd within this specific PORT.SLB file.

Long file names must be within double quotes.
Writing a rule record

Rules specify the action to take for specified attributes or footprints. Rule records contain a command followed by the names of attributes or footprints, and rule records must be preceded by a Scope record.

A rule record has three fields:

• Manipulator
• Original name
• New name

Manipulator field

This can be one of the following:

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ar</td>
<td>Rename an attribute</td>
</tr>
<tr>
<td>as</td>
<td>Skip an attribute; do not include it in the</td>
</tr>
<tr>
<td></td>
<td>translated symbol</td>
</tr>
<tr>
<td>aa</td>
<td>Add an attribute</td>
</tr>
<tr>
<td>fr</td>
<td>Rename a footprint</td>
</tr>
</tbody>
</table>

If the manipulator field is not one of these, the rule is skipped and a warning message appears.

Original name field

For rename attribute (ar) or rename footprint (fr) rules, this is the attribute or footprint’s original name (the name that was used in the .SLB file).

For add attribute (aa) or skip attribute rules (as), the original name is the name of the attribute to add or skip.

New name field

This is the new name to give the translated property. This field is used only for attribute rename (ar, fr) rules.
Index

B
bus labels and bundles in the translated schematic, 17

C
Capture
  advantages of using, 22
  commands, 32
  configuring libraries, 26
  editing parts, 29
  file types, 24
  hierarchy symbols, 30
  menus, 32
  package definitions, 30
  package information and symbols, 10
  placing and drawing items, 27
  project and design management, 24
  selecting and moving items, 28
  terminology, 36
  viewing messages in, 26
  caveats about translation, 17, 20
  configuring libraries, 26
  connectivity via wire labels in the translated schematic, 18

D
differences between Capture and Schematics, 24
  display
    of pin names and numbers, 18
    of symbol graphics, 18
    of text, 17

E
editing parts in Capture, 29

F
file types used in Capture, 24

G
glossary of Capture terms, 36
  graphics in the translated schematic, 18

H
hierarchy symbols in Capture, 30
Index

**M**
- mapping file, translator, 38
  - formatting, 39
- menu commands in Capture, 32

**P**
- package definitions in Capture, 30
- package information and symbols in Capture, 10
- pin names and numbers in the translated schematic, 18
- placing and drawing items in Capture, 27
- project and design management in Capture, 24

**R**
- rule records, 41

**S**
- scope records, 39
- selecting and moving items in Capture, 28

**T**
- terminology, 36
- text in the translated schematic, 17
- translating designs
  - stand-alone, 15
- translator
  - caveats, 17, 20
  - mapping file, 38
- TrueType fonts in the translated schematic, 17

**V**
- viewing messages in Capture, 26