CST EM STUDIO™
Tutorials

The Electrostatics Tutorial

The Magnetostatic Sensor Tutorial

The Magnetostatic Force Tutorial

The Stationary Current Calculation Tutorial

The Low Frequency Tutorial

October 11, 2005
Geometric Constructions and Solver Settings

Introduction

This tutorial deals with the simulation of a simple electrometer device that can be used for voltage measurements. The model used for the electrometer consists of three parts: the electrometer’s scale, the ground and the pointer.

The main dimensions of the electrometer device are shown in Figure 1.

![Figure 1: The Model and its main dimensions](image)

The results of interest are the capacitance and the torque for different angles of the pointer. A parameter sweep with a user-defined watch will be used for the simulation of the electrometer device. Finally, the results will be discussed.

We strongly suggest that you carefully read through the CST EM STUDIO™ Getting Started manual before starting this tutorial.
Geometric Construction Steps

This tutorial demonstrates how to perform a capacitance calculation. It will take you step-by-step through the construction of a simple electrometer for voltage measurements. The relevant screen shots will be provided so that you can double-check your entries along the way.

☐ Select a Template

After you start CST DESIGN ENVIRONMENT™ and choose to create a new CST EM STUDIO™ project, you are requested to select a template that best fits the desired field calculation of your device. Here the “Electrostatics” template should be chosen.

The template sets the dimensions of the structure to mm and the background material to “normal,” indicating material properties of vacuum, i.e. isotropic material with a relative permittivity of 1 and relative permeability of 1. The mesh settings are optimized for electrostatic calculations.

☐ Set the Units

The selected template has automatically set the geometrical dimensions to mm. Since all geometrical dimensions in this example are given in cm, you should change this setting manually. Therefore, please open the units dialog box by selecting Solve ⇒ Units… (≡) from the main menu.
Here you should set the *Dimensions* to *cm* and press OK.

Define the Electrometer’s Scale

The construction steps of the electrometer’s scale are based on the creation of circles, extrusion of a planar curve to build a solid and blending the edges of the solid.

The construction starts with the definition of two circles. Therefore, a new curve must first be defined. Please press or choose *Curves* → *New Curve* from the main menu. The newly created curve appears in the *Navigation Tree* in the folder *Curves*. Please note that no object is yet drawn in the *Modeller View*.

To create the first circle, please press or select *Curves* → *Circle*... from the main menu. Now the circle creation mode is active allowing you to enter the circle’s coordinates using either the mouse or by keyboard input. Because the exact dimensions of the circle are known, we prefer to enter the circle’s coordinates using the keyboard. Therefore, press the *Shift+Tab* keys simultaneously. A new dialog box now appears asking you to enter the center point of the circle numerically.

You can click on the *OK* button without changing any settings because the center of the circle should be at *X = 0* and *Y = 0*. Having set the center point, you are requested to enter the radius of the circle. Please press the *Tab* key and set the *Radius* to 3 in the *Enter Radius* dialog box:
Leave the dialog box by pressing OK. The Circle dialog box is now launched, allowing you to check the settings of the circle. Please note that the circle is displayed in the Modeller View with red color according to the settings in this dialog box. Changing any settings and pressing the Preview button will update the display showing the changed settings.

Finally, please confirm your settings by pressing the OK button. Now the circle is defined and appears in the Navigation Tree in the Curves ⇒ curve1 subfolder. The circle’s color has changed to blue in the Modeller View.
Similar to the first circle, the second circle will now be constructed. Press the icon or select Curves ⇒ Circle… from the main menu. The center of the second circle is located at \( X = 2 \) and \( Y = 0 \). Press the \( \text{Shift}+\text{Tab} \) keys and enter these values in the appearing Enter Point dialog box. After you have confirmed your settings with the OK button, you are prompted to enter the radius of the second circle. Press the Tab key again, enter 3.6 at the \( \text{Radius} \) text field and confirm your settings by clicking on the OK button. The Circle dialog box appears now and allows you to check the circle’s parameters again.

![Circle dialog box](image)

Please press OK here if your settings are equal to those displayed below. Now, two blue intersecting circles can be seen on the screen. These two circles are used for the next construction step to define an outline of a sickle-like structure. Therefore, one segment of each circle has to be deleted as shown below.

![Intersecting circles and delete segments](image)

You can delete the two marked circle segments by trimming the two circles and selecting the circle segments you want to delete. Therefore, it is necessary to first select one circle. Please select \( \text{circle1} \) by either double-clicking on the initially created circle in the Modeller View or by selecting Curves ⇒ \( \text{curve1} \) ⇒ \( \text{circle1} \) in the Navigation Tree.
To start the trim action, press the trim icon \( \mathbb{E} \) from the toolbar, select Curves \( \Rightarrow \) Trim Curves from the menu bar or use the shortcut keypad-(\(*\)). Next, \textit{circle2} has to be selected either from the respective folder in the \textit{Navigation Tree} or by double-clicking on it in the \textit{Modeller View}. To perform the action, confirm with the \textit{Return} key. Now the interactive trim tool highlights all curve parts that can be deleted. Delete the curve segments shown in the previous screenshot by double-clicking on the appropriate circle segment. Please check the model against the screenshot below. To confirm the trim action, press \textit{Return}.

In the next construction step, the sickle-like outline is used to create a solid. Therefore, the curve defining the sickle-like outline is extruded. First, please press the extrude planar curve button \( \mathbb{H} \) from the toolbar or select Curves \( \Rightarrow \) Extrude Planar Curve... from the main menu. You are now requested to select a profile for the extrusion. Please double-click on the inner curve item – the circle segment of the last created circle (\textit{circle2}). The \textit{Extrude Planar Curve} dialog box opens, enabling you to set the extrusion thickness, a twist angle and a taper angle.
For this tutorial, please set the *Thickness* to 0.3, do not change the settings for the *Twist Angle* or *Taper Angle* and name the solid “scale”. Press the *Preview* button to obtain a transparent view of the solid in its current state. Please ensure that the extrusion normal points in the negative z-direction. A blue arrow indicates the direction of the extrusion normal as shown in the picture below.

If the extrusion normal points in the positive z-direction you may have accidentally selected the wrong circle segment when extruding the curve. Before you can confirm your settings, the material properties of the new solid must be defined. Therefore, a new material has to be defined for the new solid. Please select *New Material…* from the material dropdown list at the bottom the *Extrude Planar Curve* dialog. The *New Material Parameters* dialog box opens and a new material can be defined.
In this dialog box you should set the Material name to “dielectric” and the Type to “Normal” dielectric material. Afterwards, you can specify the dielectric constant by entering “10” in the Epsilon field. Please select the Change… button and choose a contrasting color for the new material. Finally, you should check your settings in the dialog box again before pressing the OK button to store the material’s parameters.

Back in the Extrude Planar Curve dialog box the material has now changed to “dielectric”. Press OK to finally create the new solid. The new solid is now defined and appears in the Navigation Tree under Components ➔ Component1 ➔ scale. The initially created curve curve1 and its items circle1 and circle2 are deleted automatically. The created solid should resemble the screenshot below.
If you closely examine the created solid you may see that those edges of the solid based on the initially created circles are not displayed as accurately as desired. Therefore, for this tutorial the default triangulation accuracy should be increased to visualize the model more precisely.

Please select View → View Options… or press Alt+V and increase the Triangulation accuracy from the Shape Accuracy tab by dragging the slider closer to the high position.

Please note: This view option has no influence on the calculation. The created solid is now displayed with a higher shape accuracy as shown in the below picture.
The next construction task is to delete a part of the sickle-like shape. This can be accomplished with the “slice object by uv plane” feature. First, the **working coordinate system** (WCS) should be activated by toggling the button in the toolbar or by checking **WCS ⇒ Local Coordinate System** from the main menu. Then perform a 90° rotation around the u-axis of the local coordinate system by pressing **Shift+u** or selecting **WCS ⇒ Rotate +90° around U-axis**. Now the working plane intersects with the solid such that it splits the solid into two parts of equal size.

To actually perform the slicing, a shape must first be selected. Please select the shape **Component1:scale** from the **Navigation Tree** or double-click on it. Now you can slice the sickle-like shape by either selecting **Objects ⇒ Slice by UV Plane** from the main menu or selecting **Slice by UV Plane** from the context menu that appears if you press the right mouse button in the **Modeller View** window.
The sickle-like shape is now split into two solids that appear in the Navigation Tree.

For the electrometer’s scale, only the original solid is needed; the new one (scale_1) has to be deleted. Please select this shape and delete it either by pressing the Delete key, by selecting Delete from the context menu or by selecting Delete from the Navigation Tree when clicking with the right mouse button on the Components ⇨ Component1 ⇨ scale_1 shape.

The local coordinate system will not be used for the following construction steps. Switch it off by toggling the icon \( \text{Local Coordinate System} \) or uncheck WCS ⇨ Local Coordinate System.

The next step is to rotate the dielectric solid around the coordinate system’s origin by a parameterized value. Select the solid “scale” and open the Transform Selected Object dialog box by pressing the transform icon \( \text{Transform} \) in the toolbar or by selecting Objects ⇨ Transform… from the main menu.
Select the Rotate Operation and enter “-angle” as the rotation angle around the z-axis. After confirming with OK a new dialog box appears and asks you to enter a value for the recently introduced parameter:

Set its value to 30 and enter a helpful description text before confirming with OK. The recently defined parameter appears inside the Parameter List window. This window is usually docked at the lower left part of the user interface:

The rotated model is displayed in the screenshot below.

The next construction step is the blending of the three edges as depicted in the screenshot above. Therefore, these edges must first be picked. You may press $\bigl(\text{in the toolbar, select }\text{Objects }\Rightarrow \text{Pick }\Rightarrow \text{Pick Edge}\bigr)$ from the main menu or use the shortcut $e$
to activate the *Pick Edge Mode*. In addition, toggle the button in the toolbar or check *Objects → Pick → Keep Pick Mode* from the main menu to keep this mode after an edge is picked. Now you can pick the edges as shown in the picture above by double-clicking these edges subsequently. If all three edges are picked, leave the Pick Edge Mode by pressing the *ESC* or *Return* key. Toggle the button again to disable the keep pick feature for future picking operations (or uncheck the *Objects → Pick → Keep Pick Mode* from the main menu).

The three picked edges are highlighted with a red color in the *Modeller View*. Please now apply the blending to these edges using the *Blend Edges* dialog box by pressing from the toolbar or by choosing *Objects → Blend Edges…* from the main menu.

Enter “0.1” at the *Radius* text field and press the *OK* button to apply a blend operation with radius of 0.1 cm to all three edges. The screenshot below shows the solid with the blended edges.

![Blended Edges](image)

- Define the Electrometer’s Pointer

The construction steps of the electrometer’s pointer are based on the creation of a brick, chamfering its edges, defining a cylinder and applying Boolean operations on intersecting solids.

Initially, a brick of PEC material has to be created. Therefore, click on the button or select *Objects → Basic Shapes → Brick…* from the main menu to launch the *Brick Creation Mode*. Define the coordinates in the working plane for the first corner of the
brick by pressing the Tab key and entering values of –3.5 for the X and –0.1 for the Y coordinates in the Enter Point dialog box. Repeat this procedure for the second corner with the values 0.5 for X and 0.1 for Y. Press Tab again and set the height of the brick to 0.1.

Finally, the Brick dialog box appears, enabling you to change the settings. Please change the name to “pointer” and the material of the brick to PEC by selecting PEC from the Material drop down list. Later in the modeling process, this will enable you to define potentials or charges to the pointer.

![Brick dialog box](image)

Please check your settings before you confirm with the OK button. The recently created brick “pointer” is shown together with the electrometer’s scale in the screenshot below.

![Screenshot of the new shape pointer](image)

The new shape pointer needs a spike for the visualization. This is accomplished by chamfering two front edges (see screenshot above). First, the two edges have to be
picked using the button in the toolbar or selecting Objects ⇒ Pick ⇒ Pick Edge from
the main menu for each button. The activation of the Keep Pick Mode as described
above is not of advantage in this case.

Similar to the blending of the edges of the electrometer’s scale, the chamfering is applied
to the currently selected edges. Press the button in the toolbar or select Objects ⇒
Chamfer Edges... from the main menu and enter a Chamfer width of 0.1 in the
subsequently opening dialog box.

Press OK to apply the chamfer operation and to close the dialog box. The chamfered
brick is displayed in the screenshot below.

The pointer features a hole at the origin of the global coordinate system – the axis hole.
This hole can be modeled by defining a cylinder centered on the origin of the global
coordinate system. Please click the button on the toolbar or select Objects ⇒ Basic
Shapes ⇒ Cylinder to launch the Cylinder Creation Mode.

Using the Shift+Tab keys enables you to define the center at X = 0 and Y = 0 in the
appearing Enter Point dialog box. Next, you are requested to enter the radius of the
cylinder. Please press the Tab key and set the Radius to 0.05 in the upcoming dialog
box.
After confirming with OK, you are requested to enter the height of the hole. It should be as high as the pointer. To ensure this, pick a point from the pointer, e.g. one of two proposed in the next screenshot. Therefore, either click on the button on the toolbar, select Objects ⇒ Pick ⇒ Pick Point in the main menu or just use the shortcut p.

To pick the point that defines the height of the cylinder, just double-click on one of the two highlighted points depicted in the above screenshot. Now that the height is defined, you are requested to define the inner radius of the cylinder. Because no inner radius is needed for this cylinder, press the Esc key to leave the Cylinder Creation Mode. Finally, the Cylinder dialog box opens, enabling you to set the material properties of the cylinder. Please ensure that the Vacuum material is selected from the Material drop down list.
Please check your settings and create the cylinder by pressing the OK button. When defining the cylinder the program will detect an intersection with the already defined pointer. The Shape Intersection dialog box will appear and ask you how this intersection should be handled. Because the created cylinder models the axis hole, the cylinder should be cut away from the pointer brick.

Check the Cut away highlighted shape radio button and confirm with OK. The current model status is shown in the screenshot below.
Define the Electrometer’s Ground

The last solid that must be modeled is the ground. It will be constructed using the extrusion tool. Pick the face of the dielectric solid (scale) as shown in the screenshot. Use the button \( \text{Pick face} \), select Objects \( \Rightarrow \) Pick \( \Rightarrow \) Pick Face or just use the shortcut \( f \) to enter the Pick Face Mode. Afterwards, double-click on the electrometer’s scale’s face that is located on the opposite side of the pointer.

Now please activate the extrusion tool either by using the \( \text{Extrude} \) button in the toolbar or selecting Objects \( \Rightarrow \) Extrude from the main menu. Please name the solid “ground”, set the Height to 0.1 and set the Material to PEC in the appearing Extrude Face dialog box.
After you have created the new solid by pressing the OK button, the structure’s modeling is now complete. Closely examine the model and check it against the screenshot given below before continuing with the definition of the electrical properties.
Solver Settings

Define Potentials, Background Material and Boundary Conditions

For proper function of the electrometer, a voltage source between the two PEC regions must be defined. This can be accomplished with two potential definitions.

Activate the potential tool (or select Solve ⇒ Electric Potential...). Once activated just double-click on the “pointer” solid and enter the Potential value of 1000V in the Define Potential dialog box.

After setting the new potential source with the OK button, the definition of the grounds potential follows. Please note that the definition of this potential is necessary to calculate the capacitance matrix (only potential and charge definitions will be considered for the capacitance matrix). Set the ground potential to 0 V in a manner similar to that for the pointer’s potential (or select Solve ⇒ Electric Potential...).
Leave the dialog box with OK. The screenshot below shows the structure with the potential settings of the electrometer’s ground and pointer.

Please note: All PEC regions that are not defined with a potential will be given a potential of 0 V internally unless they touch another PEC region with a defined potential. In the latter case this defined potential is used for the internal potential setting. The implicitly set potentials are not visualized in this view.

The default setting for the background material has to be adapted to the problem. Open the background properties dialog by pressing the toolbar button or selecting Solve ➞ Background Material... from the main menu. Add surrounding space to the current calculation domain by setting the distance to the calculation domain’s boundaries to 1. Therefore, check the Apply in all directions check-box and enter a value of 1 in the Distance field. Please ensure that the Material type is kept unchanged as Normal. Please verify your settings against the following plot of the Background Properties dialog box.
These settings will lead to a simulation with 1 cm additional vacuum space in each direction. Finally confirm the new background setting with the OK button.

After the definition of the background material properties, the boundary conditions are set for the simulation. For the modeled problem, no symmetry conditions can be used and the device has to be modeled in free space. Thus, all boundary conditions should be changed from type electric to type open. To set the boundary conditions, please click on the button on the toolbar or select Solve → Boundary Conditions… from the main menu.

As soon as you enter the Boundary Conditions dialog box, the currently set boundary conditions are displayed together with the model in the Modeller View. The following screenshot demonstrates this with the open boundary conditions set from this dialog box.
After you have changed all boundaries to type open, confirm your settings with the OK button.

Define the Solver Settings, Setup the Parameter Sweep and Start the Calculation

The calculation of the electrostatic fields should be performed for several pointer angles. Therefore, a parameter sweep for the previously defined parameter “angle” will be performed. The first step is to set the solver parameters. Therefore, launch the Electrostatic Solver Parameters dialog box by pressing the button or choose Solve \( \Rightarrow \) E-Static Solver... from the main menu. Please check the Calculate capacitance matrix button to enable the capacitance matrix calculation. This is necessary because a capacitance watch for the parameter sweep will be defined. Leave the other settings at their default values.
With the *Mesh Type* setting you may select between a hexahedral or tetrahedral mesh to discretize the calculation domain. The chapter “Tetrahedral Meshing Strategy” will focus on this subject. For the moment, leave this setting on “Hexahedral Mesh”.

Continue with setting up the parameter sweep by pressing the *Par. Sweep…* button now. The *Parameter Sweep* dialog box opens and the *Electrostatic Solver Parameters* dialog box is closed. First, you should add a sweeping sequence to the parameter sweep by clicking on the *New seq.* button. The *Sequence 1* appears now in the *Sequences* frame of the dialog box. Now the sweeping parameter has to be added to the newly defined sequence. Therefore, clicking on the *New par.* button leads you to the next dialog box – the *Parameter Sweep Parameter* dialog box.

Please choose the only available parameter “angle” from the *Name* drop list and check the *Sweep* button in this dialog box. Now you can enter the range that is used for the variation of the parameter by typing “20” in the *From* field and “70” in the *To* field. In addition, enter “11” in the *Steps* field. These settings indicate that the pointer angle is varied from 20° up to 70° in steps of 5° when the parameter sweep is running.
Finally, it is necessary to add at least one watch for the parameter sweep that records results from the individual calculation; this will allow a comparison of the different calculations with regard to the parameter value.

Check the Add watch… drop down list from the result watch frame and choose Capacitance Matrix from the list. If the watch is not available, the Calculate capacitance matrix from the electrostatic solver dialog may have not been activated.

A second watch is used in this tutorial to analyze the torque on the pointer for a moment axis in the positive z-direction from the coordinate axis origin. Therefore, select Force… from the watch drop down list to open the parameters dialog box for the force watch.
Select the pointer’s solid from the Solidname drop down list (component1:pointer) and Torque as the watch Component. The default axis and origin can be used, so no further settings are required. After pressing the OK button the settings are stored and the watch is displayed in the result watch list.

Finally, press the Start button from the Parameter Sweep dialog. The results are generated by different solver runs with the structure modified by the parameter variation.
Results

One of the main results is the capacitance between pointer and ground. This result is automatically generated by the capacitance watch and can be accessed under the “tables” folder in the navigation tree. There you can select Tables \( \Rightarrow \) Capacitance [potential2] [potential1] to view the capacitance plotted vs. the pointer angle. Please compare your result with the following screenshot of the capacitance. It can be seen that the geometry results in a quadratic variation in the capacitance as a function of angle.

The strong relationship between capacitance and torque leads to a linear torque with respect to the angle. Therefore, this allows the use of this device as a measuring instrument. Select Tables \( \Rightarrow \) Torque (component1)(pointer) in the Navigation Tree to view the torque plotted vs. the pointer angle. It should look like the screenshot below.
Accuracy Considerations

A static field calculation is mainly affected by two sources of numerical inaccuracies:

1. Numerical errors introduced by the iterative linear equation system solver.
2. Inaccuracies arising from the finite mesh resolution.

In the following section we provide hints on how to minimize these errors and achieve highly accurate results.

 Numerical errors introduced by the iterative linear equation system solver.

CST EM STUDIO™ uses an iterative linear equation system solver to solve the discretized field problem. This means that the iterative solver will stop a calculation if a given accuracy has been reached. Generally, the accuracy setting of 1e-4 is sufficient for most calculations. In some cases, however, the solver will give you a warning that results are inaccurate and that you should consider increasing the solver accuracy.

 Inaccuracies arising from the finite mesh resolution.

Inaccuracies arising from the finite mesh resolution are usually more difficult to estimate. The only way to ensure the accuracy of the solution is to increase the mesh resolution and recalculate the results. When they no longer significantly change as the mesh density is increased, then convergence has been achieved.

In the above example, you have used a modified default mesh. The easiest way to test the accuracy of the results is to use the fully automatic mesh adaption that can be switched on by checking the Adaptive mesh refinement option in the solver control dialog box (Solve ⇒ E-Static Solver, ![Button](image.png)):

![Image of Electrostatic Solver Parameters](image.png)

After activating the adaptive mesh refinement tool, you should now start the solver again by pressing the Start button. After the mesh adaption procedure has finished, you can visualize the maximum difference of the energy error for two subsequent passes by selecting 1D Results ⇒ Adaptive Meshing ⇒ Error from the navigation tree:
As evident in the above plot, the maximum energy deviation is almost 4% between the first and the second pass, indicating that the adaptive mesh refinement was required here to obtain highly accurate results.

Generally speaking, global results like energies are less susceptible to discretization errors than local results like field values.

When analyzing the refined mesh, you should note that it has been especially refined around the pointer’s edges and in the z-direction inside the dielectric scale.

This knowledge can be used to manually improve the expert-based mesh. A manually refined mesh offers the advantage of saving computation time because the mesh adaptation can be switched off for the next parameter sweep.

Because fields change rapidly on the pointer’s edges and not inside the pointer’s volume, it is advisable to apply an edge refinement to this body. In contrast, the mesh adaptation refined the mesh inside the dielectric scale in the z-direction. Therefore, it is convenient to specify a maximum z-step-width inside the “scale” solid.
Select the pointer in the navigation tree by clicking Components ➔ Component1 ➔ pointer. Activate the context menu by selecting Edit ➔ Mesh Properties…. A dialog opens where mesh settings for particular solids can be adjusted. Activate the checkbox Use local Edge refinement factor and increase its refinement value to 10:

![Mesh Properties dialog]

After confirming the mesh setting with OK, you are asked whether or not to delete the existing results. Again press OK. Afterwards, you can examine the mesh in the yz plane:

![Mesh in yz plane]

To refine the mesh inside the “scale” solid, select it in the navigation tree by clicking Components ➔ Component1 ➔ scale and open its mesh properties by choosing Edit ➔ Mesh Properties…:
Enter a maximum step-width value of 0.02 in the z-direction and confirm with the OK button.

The manually refined mesh includes the information extracted from the previous adaptation sequence. It has been sufficiently refined and you may therefore enter the solver dialog box again (Solve ⇒ E-Static Solver) and switch off the adaptive mesh refinement checkbox. Afterwards, start the parameter sweep with the improved mesh by entering the parameter sweep dialog and pressing the Start button. A few minutes later the sweep is completed and you can examine the tables again. You will notice that the capacitance curves have not changed significantly, while the torque curve now meets the expectations much better compared to the first sweep:
Because field singularities appeared on the pointer's PEC edges, the mesh refinement within these regions allowed the solver to produce more accurate results. On the other hand, these fields are used to compute the pointer's torque. So in this case, you have a global result depending strongly on local field values.

**Tetrahedral Meshing Strategy**

As mentioned above, CST EM STUDIO™ provides two types of mesh. During the previous chapters you became quite familiar with the hexahedral meshing strategy. To get an impression of the tetrahedral meshing method, we recommend that you read this chapter.

Before you begin to perform a single tetrahedral simulation, it is advisable to make a copy of the current project under a different name. Therefore, enter file dialog via File ➔ Save As... and make a copy of the current project. After confirming with the Save button you can enter the electrostatics dialog (Solve ➔ E-Static Solver) and activate the Tetrahedral Mesh Type:
Start the simulation with the *Start* button and confirm the deletion of the previous calculated results. A couple of seconds later, the calculations have been finished and you can examine the tetrahedral mesh and the appropriate results.

First, select *Mesh ⇒ Mesh View* ( ) in order to get an impression of the tetrahedral mesh:

Although this mesh is pretty coarse, it delivers a good impression about the fields. Select the *Potential* entry from the *2D / 3DResults* folder in the navigation tree:

Finally, you might take a look at the electric field (*NT ⇒ 2D / 3DResults\E-Field*):
An adaptive mesh refinement is also available for the tetrahedral meshing method. Reenter the solver's dialog box (Solve ⇒ E-Static Solver ) and activate the adaptive mesh refinement:

Before you restart the solver, enter the adaptive mesh properties dialog by pressing the Properties button:
Since the hexahedral adaptation run was able to deliver a relative error of less than 1%, you may also this time set the convergence criteria to a value of 0.01. Leave the dialog by pressing the OK button and start the tetrahedral adaptation run by pressing Start. A couple of minutes later you can observe the refined mesh by activating the mesh view Mesh ➔ Mesh View ( ⏯️):

The mesh has been refined roughly at the same locations where the hexahedral method added new mesh lines, specifically, the surroundings of the pointer. Finally, examine the adaptation convergence curve by selecting 1D Results ➔ Adaptive Meshing ➔ Error from the navigation tree:
The relative error between two subsequent passes dropped below 1% within 4 calculation passes.
Getting More Information

Congratulations! You have just completed the electrometer tutorial that should have provided you with a good working knowledge on how to use the electrostatic solver. The following topics have been covered:

1. General modeling considerations, using templates, etc.
2. Modeling curves using the circle creation tool in combination with trim curves tool.
3. Creating shapes from planar curves using the extrusion tool.
4. Model shapes using the cylinder- and brick creation tool.
5. Applying blend and chamfer operations on existing shapes.
6. Define potentials on PEC solids.
7. Define boundary conditions.
8. Setup the electrostatic solver.
10. Perform a parameter sweep.
11. Visualize the results of the parameter sweep.
12. Obtain accurate and converged results using the automatic mesh adaption.

You can obtain more information for each particular step from the online help system that can be activated either by pressing the *Help* button in each dialog box or by pressing the *F1* key at any time to obtain context sensitive information.

In some instances, we have referred to the *Getting Started* manual that is also a good source of information for general topics.

In addition to this tutorial you can find more electrostatic calculation examples in the “examples” folder in your installation directory. Each of these examples contains a *Readme* item in the navigation tree that will give you more information about the particular device.

And last but not least: Please also visit one of the training classes, held regularly at a location near you. Thank you for using CST EM STUDIO™!
The Magnetostatic Sensor Tutorial

Modeling 42
   Introduction and Model's Dimensions 42
   Geometric Construction Steps 42
   Further Physical Settings 59

Hexahedral Solver 60
   Solver Settings 60
   Results 66

Tetrahedral Solver 69
   Solver Settings 69
   Results 75

Parameterization 77

Accuracy Considerations 85

Getting More Information 88
Modeling

Introduction and Model’s Dimensions

In this tutorial you will analyze a sensor with the magnetostatics field simulator. The structure is a rotary encoder that consists of two iron yokes, a permanent magnet and two Hall sensors. Both yokes form a magnetic circuit that is driven by a cylindrical permanent magnet. Two Hall sensors are placed in the air gap between the yokes to measure the flux density. When the yokes are twisted, the B-field changes almost linearly with the rotation angle. After the construction process has been completed you will use the parameter sweep feature to check the linearity of the device.

We strongly suggest that you carefully read through the CST EM STUDIO™ Getting Started manual before starting this tutorial.

Geometric Construction Steps

- Select a Template

Once you start CST DESIGN ENVIROMENT™ and choose to create a new CST EM STUDIO™ project, you are requested to select a template that best fits your current device. Here the “Magnetostatics” template should be chosen.
This template automatically sets the dimensions unit to mm, the background material to "Normal" and all boundaries to be of type electric (the meaning of boundary types will be introduced in the chapter “Solver Settings”).

Define Background Properties

Because the structure will be defined in a vacuum background, you must define the size of the surrounding empty space. Therefore, select Solve ➔ Background Material to enter the background material dialog box:
For this example, activate the checkbox *Apply in all directions* and enter a *Distance* value of 20. This value ensures an adequate distance between the calculation domain’s boundaries and the structure. Confirm your settings by pressing the OK button.

- **Define Working Plane Properties**

  The next step will usually be to set the working plane properties to make the drawing plane large enough for your device. Because the structure has a maximum extension of 40 mm along a coordinate direction, the working plane size should be set to at least 40 mm. These settings can be changed in a dialog box that opens after selecting *Edit ➪ Working Plane Properties* from the main menu. Please note that we will use the same document conventions here as introduced in the *Getting Started* manual.

  Change the settings in the working plane properties window to the values given above. After unchecking the *Auto* checkbox for both raster settings, leave the dialog box by pressing the OK button.
Define the First Cylinder

Now you can go ahead and create the first cylinder. The easiest way to do this is to click the "create a cylinder" icon or select Objects \ Basic Shapes \ Cylinder from the main menu.

CST EM STUDIO now asks you for the center point of the cylinder. The current coordinates of the mouse pointer are shown in the bottom right corner of the drawing window in an information box. You can set the circle's center point with a double-click, but it is easier to enter the value numerically by pressing the Tab key. This will open the following dialog box:

Enter the value 0 for the X and Y coordinates to set the circle’s center point. Confirm with the OK button. Afterwards you can repeat these steps to set the circle’s radius:

1. Press the Tab key.
2. Enter Radius = 20 in the dialog box and press OK.

The height of the cylinder can be defined in the same manner:

1. Press the Tab key.
2. Enter Height = 5 in the dialog box and press OK.

The setting of the cylinder's inner radius can be skipped by pressing the Esc key. Now the following dialog box will appear, displaying a summary of your previous input:
Please check all these settings carefully. Whenever you encounter a mistake, please change the value in the corresponding entry field.

You should now assign a meaningful name to the cylinder by entering e.g. “bottom yoke” in the Name field.

You still need to define the iron material for the cylinder. Because no material has yet been defined for the iron, you should open the material definition dialog box by selecting New Material from the material drop down list.

In this dialog box you should define a new Material name (e.g. Iron-1000) and set the Type to a Normal material. Afterwards, specify the material properties in the Epsilon and Mu fields. Here, you only need to change the permeability Mu to 1000. Finally, choose a color for the material by pressing the Change button. Your dialog box should now look similar to the above picture before you press the OK button.

Back in the cylinder creation dialog box you can also press the OK button to finally create the bottom yoke brick. Your screen should now look as follows (you can press the Space key in order to zoom the structure to the maximum possible extent):
Model the Yoke’s Shoulder

The next step is to model the yoke’s shoulders. Therefore, you should first move the drawing plane on top of the bottom cylinder. This can be easily achieved by activating the face pick tool (`Objects ⇒ Pick ⇒ Pick Face`, `f`, Shortcut: `f`) and double-clicking on the cylinder’s top face as shown above. The face selection should then be visualized as follows:

After the face has been selected, you can align the working coordinate system (WCS) with its plane. Therefore, please either select `WCS ⇒ Align WCS With Selected Face` from the main menu, press the toolbar button `align` or simply use the shortcut `f` . Now the
The last step of the working plane adjustment is a rotation around the v-axis. Select WCS $\Rightarrow$ Rotate Local Coordinates and perform a rotation around the v-axis of $-90$ degrees.

After you have confirmed with the OK button, the view should appear similar to the following picture:
With an adjusted WCS it is fairly simple to create the rotation body. Activate the Rotate Tool by selecting Objects ⇒ Rotate ( ).

You will be asked to enter the uv-coordinates of the profile to rotate. Again, you may enter them numerically or via the graphical user interface. As for the construction of the cylinder, press the Tab key to enter the profile’s coordinates and confirm your settings with OK. The profile’s coordinates are listed below:
After the last point has been set, the Rotate Profile dialog box appears. Now you can review your settings and adjust the rotation angle. The Start Angle will be –30 degrees for a rotation Angle of 60 degrees around the U-Axis:

<table>
<thead>
<tr>
<th>Point</th>
<th>U</th>
<th>V</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0</td>
<td>-20</td>
</tr>
<tr>
<td>2</td>
<td>0</td>
<td>-15</td>
</tr>
<tr>
<td>3</td>
<td>5</td>
<td>-15</td>
</tr>
<tr>
<td>4</td>
<td>5</td>
<td>-20</td>
</tr>
<tr>
<td>5</td>
<td>0</td>
<td>-20</td>
</tr>
</tbody>
</table>

There is no need for a special name because the body will be added to the cylinder later; therefore, just press OK to define the solid.
The yoke’s second shoulder can be simply created by a mirror transformation. Select the previously created shoulder by double-clicking on it (you may also select its item in the navigation tree: NT ⇒ Components ⇒ component1 ⇒ solid1). Then open the Transform dialog box by selecting Objects ⇒ Transform Shape ( ). In this dialog box you should change the Operation to Mirror before you set the V-coordinate of the Mirror plane normal to 1. Afterwards, please switch on the Copy and Unite options to copy the existing shape before mirroring it, and to unite the original shape with the mirrored copy.
Finally press OK to create the second shoulder. In order to unite the bottom cylinder with the shoulders, select the cylinder with a double-click or in the tree and activate the Boolean add tool by selecting Objects $\Rightarrow$ Boolean $\Rightarrow$ Add (\textcolor{red}{\textbf{[E]}}). Now you will be prompted to select the object to be added. Double-click on one of the shoulders and confirm with the Return Key. The construction of the bottom yoke is now finished.

$\square$ Model the Permanent Magnet

The construction of the permanent magnet consists of two steps. First, you must create a cylinder with a new material and then assign the permanent magnet properties to the object. For the cylinder definition the WCS has to be rotated back. Simply press Shift-v to rotate the WCS 90 degrees around the v axis counter-clockwise to its previous orientation.
Now activate the cylinder tool again (Objects $\Rightarrow$ Basic Shapes $\Rightarrow$ Cylinder (рис.)) and perform the following settings:

1. Press the Tab key.
2. Enter the center point $u = 0, v = 0$.
3. Confirm with OK.
4. Press the Tab key.
5. Enter the Radius: 10.
6. Confirm with OK.
7. Press the Tab key.
8. Enter the Height: 11.
9. Confirm with OK.
10. Press the Esc key to skip the definition of the inner radius.

After you have carefully checked your settings in the dialog box, select a name for the shape (e.g. “magnet”). Before you create the shape you should define a new material where the material properties will be stored. The procedure is the same as for the yoke’s material:

1. Select the New Material button in the Cylinder dialog box.
2. Enter a material name (e.g. “magnet material”).
3. Set the type to “Normal”.
4. Select a color.
5. Confirm with OK.

Back in the cylinder dialog box you should select the newly defined material if it has not been already selected.
Now create the cylinder by pressing OK.

The next step is to define the permanent magnet’s magnetization vector. Therefore, activate the permanent magnet tool by selecting Solve $\Rightarrow$ Permanent Magnet ( ). Now you will be asked to select the magnet’s surface with a double-click. Move the mouse cursor on the previously defined cylinder and select it with a double-click. The selected surface will be highlighted in red and a dialog box will open where you should define the magnet’s properties:
Enter 0.2 for the \( W \)-component of the magnetization vector. Pressing the `Preview` button displays the orientation of the current magnetization vector. To store your settings press `OK`. The permanent magnet definition can always be reviewed by selecting its icon in the “Permanent Magnets” folder.

- **Model the Hall Sensors**

It is not necessary to model the Hall sensors because the material properties of the sensors are neutral for a magnetostatic simulation. Nevertheless, the sensors are included for two reasons: to visualize their positions and to refine the mesh within the sensors’ regions.

Before the sensors are constructed, the WCS must be shifted along the w-axis. Enter the `Move Local Coordinates` dialog box by selecting `WCS \( \Rightarrow \)` `Move Local Coordinates` (\( \Rightarrow \)). Now enter \( dW = 5 \) for a shift along the w-axis and confirm with `OK`.

The working plane has been shifted to the top faces of the shoulders, where the Hall sensors will be constructed.
With the WCS in the proper location, construction of the first Hall sensor is fairly simple. Enter the cylinder tool (Objects ➔ Basic Shapes ➔ Cylinder (Ω)) and perform the following steps:

1. Press the Tab key.
2. Enter the center point coordinates u = 0 and v = 17.5.
3. Confirm with the OK button.
4. Press the Tab key.
5. Enter the radius: 2.
6. Confirm with the OK button.
7. Press the Tab key.
8. Enter the height: 1.
9. Confirm with the OK button.
10. Press Esc to enter the cylinder dialog box directly.

Just as for the creation of the permanent magnet, you can enter a meaningful name (e.g. "Hall sensor 1"). You should also define a new material with normal properties (Eps = 1 and Mue = 1) for the sensors. Do not forget to select a unique color to improve the visualization.
After confirming the setting with OK the structure should appear as follows:

The second Hall sensor will be created by a transformation of the first one. Select the Hall sensor by double-clicking on it and activate the Transform dialog box (Objects $\rightarrow$ Transform Shape, $U^3$). Here, you should select the Operation type "Translate" and set the translation vector’s V-component to a value of –35. To create a transformed copy of the first sensor, activate the Copy box.
Press the Preview button to check your settings before you confirm with OK.

Model the Top Yoke

The last steps include the construction of the top yoke and the rotation of the bottom yoke to the sensor’s zero position. First, the bottom yoke will be rotated to its final position. Therefore, select the bottom yoke with a double-click (or its icon in the navigation tree) and open the Transform dialog box (Objects ⇒ Transform Shape, ). Select the “Rotate” Operation and enter a Rotation angle of 20 degrees around the W-axis. You should obtain the following preview:

If all settings are correct, finalize with the OK button.
The next step is the creation of the top yoke. Reselect the bottom yoke and enter the Transform dialog box again (Objects ➤ Transform Shape, \( \mathbb{D} \)). Enter the following settings in the dialog box and use the Preview button to check it:

1. Select the “Mirror” Operation.
2. Enter the value \( W_0 = 0.5 \) to shift the origin of the mirror plane along the w-axis.
3. Enter \( W = 1 \) to define the uv-plane as the mirror plane.
4. Select Copy to create a transformed copy of the bottom yoke.

After you have confirmed with OK, the top yoke will be created. Finally, the newly created solid should be renamed. Select it with a double-click in the main view or by clicking at its icon inside the navigation tree (\( NT ➤ Components ➤ component1 ➤ bottom yoke_1 \)) and select: Edit ➤ Rename (F2). If you examine the navigation tree, you will recognize that the item text of the selected body can be edited. Enter an appropriate name (e.g. “top yoke”) and confirm with the Return key.

The geometric construction is now complete. Before the simulation can be started, some physical settings must be adjusted.

**Further Physical Settings**

- Define Boundary Conditions

The calculation domain is covered and terminated by six faces. You must assign a boundary condition to each of these faces. Because the structure is almost in a closed magnetic circuit, it is sufficient to use boundaries of type “electric”. The electric boundary condition forces the normal component of the magnetic flux density to be zero. It appears to be like a perfect electric conductor (PEC). The table below shows the conditions for different field types at different boundary conditions:
Because fields outside the magnetic circuit do not have significant impact on the device’s behavior, it is advisable to use electric boundaries and add some space around the structure. Enter the boundary conditions dialog box by selecting Solve ⇒ Boundary Conditions (\(d\)). After the dialog box appears, you will notice that the main view changes. In addition to the dialog box entries, the boundary conditions are also displayed in the main view.

For each boundary the type “electric” has to be chosen. Afterwards, confirm your settings with the OK button.

**Hexahedral Solver**

**Solver Settings**

For the numerical solution of a field problem, it is necessary to discretize its calculation domain. This means that the volume will be subdivided into small cells, or in alternate terms that a mesh will be put on the structure. CST EM STUDIO™ automatically generates a calculation mesh that can be modified by the user in many ways. The second chapter of this tutorial will focus on the hexahedral solver method, while the third one introduces the tetrahedral method.

To examine the automatically generated mesh, activate the Mesh view by selecting Mesh ⇒ Mesh View, \(d\).
The above picture shows the x-meshing plane at the x-position = 0. You can use the tools on the grid toolbar to switch to another mesh plane normal \((x, y, z)\) or to vary the mesh plane index \((x, y)\).

This mesh is too coarse inside the air gap and iron yokes to deliver reliable results. The strongest refinement needs to be applied to the Hall sensors and the air-gaps between the yokes’ shoulders because the highest energy values are expected within these regions. Moreover, the magnetic fluxes will change rapidly at the material transitions at the air-gaps. The two yokes have to be refined with a lower factor because no high energy values or rapid field variations are expected inside these regions.

In order to refine the mesh in the air-gaps you will assign solid-based mesh properties to the two Hall sensors. Select “Hall sensor 1” by double-clicking on it or selecting its tree icon. Open the objects Mesh Properties dialog box by selecting Edit \(\Rightarrow\) Mesh Properties:

The upcoming mesh properties dialog box shows the mesh settings for the Hall sensor 1. For this example, a volume refinement is necessary. Therefore, activate the Use local volume refinement factor and set the factor to 8. In order to extend the refined mesh area to the complete air gap, enter the values 15 mm, 7 mm and 1 mm for the \(X / Y / Z\) extension ranges.
When you press the OK button the settings will be stored and the dialog box will close. Apply these mesh properties settings to the second sensor “Hall sensor 1_1” by repeating the steps described above for the second sensor.

**Please note:** A high refinement setting for a certain solid is only recognized when the global ratio limit value that describes the ratio between the smallest and the largest line distance, is not exceeded. This value can be verified by opening the global mesh properties dialog box (Mesh > Global Mesh Properties, 🗄):
The mesh line ratio limit value (50) that has been set by the magnetostatics template is relatively high. Consequently, a volume refinement factor for a single solid is correctly considered. Because no settings have to be changed here, leave the dialog box by pressing the Cancel button and take a look at the refined mesh around the Hall sensors:

The mesh inside the air-gaps has been refined adequately, but the yokes need further refinement to properly sample the magnetic flux density. Apply the refinement procedure from the Hall sensors for the two iron yokes:
1. Select the body (bottom yoke / top yoke) with a double-click.
2. Select Edit ⇒ Mesh Properties.
3. Set a local volume refinement factor of 3.
4. Set the X, Y, Z extension ranges to a value of 2 and confirm with OK.

Finally, the mesh view at the x-meshing plane at the x=0 position should resemble the following:
Now the fields are sufficiently sampled inside the most important regions. Before starting the solver process, leave the Mesh View by selecting Mesh ⇒ Mesh View (Ctrl) again.

☐ Start the Solver

The solver parameters are specified in the magnetostatic solver control dialog box that can be opened by selecting Solve ⇒ M-Static Solver from the main menu or by pressing the corresponding icon ( ) in the toolbar.

Ensure that the Hexahedral Mesh is selected from the Mesh Type list. Without any modifications you can start the simulation process by pressing the Start button.

After the solver is started the progress is shown in the lower left corner of the main window:

This progress bar disappears after the solver has successfully completed. Otherwise, error messages or warnings appear inside the message window that is usually docked at the lower right corner of the user interface.
Results

Congratulations, you have simulated the rotary encoder! Let’s examine the calculated fields. You will notice that some new entries have appeared in the Navigation Tree (NT):

Because this tutorial focuses on the magnetic flux density within the Hall sensors, the subject of interest is the B-Field item in the tree. Select NT → 2D/3D Results → B-Field to visualize the magnetic flux density in the entire calculation domain:

This plot gives you an initial impression about the fields in and around the magnetic circuit. For a more detailed analysis it is appropriate to activate the 2D plot in a plane, by selecting Results → 3D Fields on 2D Plane:
When you select a component in the \textit{B-Field} folder (e.g. NT $\Rightarrow$ 2D/3D Results $\Rightarrow$ B-Field $\Rightarrow$ Z), a contour plot of the selected component appears:

It is always possible to modify plot settings, therefore select \textit{Results} $\Rightarrow$ \textit{Plot Properties}:
You may change the Plot type to “Isoline”. After a few seconds a new plot appears inside the main view:

For more information on this subject, please refer to the online help (Help button or F1 key).
Tetrahedral Solver

This chapter introduces the tetrahedral solver method for the magnetostatics solver. A comparison between the two available methods allows you to verify the accuracy of the results. Although the hexahedral meshing method will be faster for this particular example, a tetrahedral mesh is usually the first choice when thin and curved structure details have to be accurately sampled. The seamless combination of these different techniques in a homogeneous environment is another outstanding feature of CST EM STUDIOTM.

Solver Settings

First, activate the Mesh view by selecting Mesh → Mesh View ( ). If the hexahedral mesh is still activated, you can switch to the tetrahedral meshing type by first opening the global mesh properties dialog box (Mesh → Global Mesh Properties, ):

First, select the Tetrahedral Mesh type. To obtain an acceptable basic sampling rate, set the Min. number of steps to a value of 30. Leave the dialog box by pressing OK. The mesh is not generated automatically, but a message appears inside the main view:

Press 'Mesh→Update' to update mesh representation

In contrast to the hexahedral mesh generation, tetrahedral meshes require substantially more time to create. As a consequence, this operation is only performed upon request. To create a first tetrahedral mesh simply carry out the instructions printed inside the view (Mesh → Update, ):
To check the mesh on a 2D cut-plane, activate the cutting plane dialog box by selecting View → Cutting plane (>):

Use the Position slider and Axis radio-buttons to get an impression of the mesh inside the structure. Finally, leave the dialog box by pressing the Close button.
You might also want to examine the mesh inside the background regions. To activate the background material display, select View ⇒ View Options (\texttt{View Options}) and activate the \textit{Background material} checkbox on the General tab:

To update the view, finally press \textit{Apply}. If the cutting plane is still activated you should get a picture similar to the following:
To navigate through the mesh, reopen the cutting plane dialog box by selecting View ➔ Cutting plane ( ). Use the Location slider controls to reposition the cutting plane. Before you leave the dialog box, activate the No cutplane button inside the Cutplane Control frame to restore the 3D mesh view. Afterwards, reenter the view options dialog box to disable the Background material display.

In the same manner that you improved the mesh for the hexahedral mesh by defining refinements for particular solids, you should do the same for the tetrahedral mesh. Therefore, select the first Hall sensor (with the mesh view activated) and open the context sensitive menu with a right-mouse-click:

Select Mesh Properties in order to open the corresponding dialog box.
For tetrahedral meshes a \textit{Maximum step width} can be specified here. Enter a value of 0.2 and leave the dialog box by pressing \textit{OK}. Before the dialog box closes, you are requested to confirm whether the existing mesh should be deleted. Confirm with \textit{OK} and repeat the entire refinement procedure for the second Hall sensor. Instead of selecting the second sensor and calling the dialog box through the context sensitive menu, it is also possible to open it directly by double-clicking on the item in the navigation tree (only with activated mesh view).

To refine the yokes and magnet, apply the same procedure to these solids. Instead of using a Maximum step width of 0.2, use a step width of 2.

<table>
<thead>
<tr>
<th>Solid</th>
<th>Max. stepwidth</th>
</tr>
</thead>
<tbody>
<tr>
<td>bottom yoke</td>
<td>2</td>
</tr>
<tr>
<td>top yoke</td>
<td>2</td>
</tr>
<tr>
<td>magnet</td>
<td>2</td>
</tr>
<tr>
<td>Hall sensor 1</td>
<td>0.2</td>
</tr>
<tr>
<td>Hall sensor 1_1</td>
<td>0.2</td>
</tr>
</tbody>
</table>

After a final update (\textit{Mesh $\Rightarrow$ Update}) that may take a couple of seconds, you should see the following mesh:
Start the Solver

Open the magnetostatic solver control dialog box by selecting Solve \(\rightarrow\) M-Static Solver from the main menu or by pressing the corresponding icon (in) in the toolbar. The Mesh Type *Tetrahedral Mesh* is already selected because this setting is related to the one inside the global mesh properties dialog box.

Without any further modifications you can start the simulation process by pressing the Start button. Again you can observe the solver process on the lower left corner of the main view.
Results

You have simulated the rotary encoder with the tetrahedral meshing method. In addition to the hexahedral simulation workflow, you are invited to examine the result fields. A first look at the Navigation Tree shows that entries for the Magnetostatic fields and flux densities have been added.

Again, you might quickly examine the B-Field by clicking on its icon in the navigation tree:

To observe the fields in a 2D cut plane, activate the context menu inside the main view and select Results ⇒ 3D Fields on 2D plane:
To change plot positions and other settings, select \textit{Results} $\Rightarrow$ \textit{Plot Properties}: from the main menu:

The tetrahedral mesh method is often applied on structures that cannot be adequately sampled inside a structured Cartesian mesh without reasonable effort. Sometimes you may prefer observing the fields in an arbitrary 2D cutplane because the interesting parts
of a structure are not aligned to the x/y/z Axis. Therefore, select the Free cutplane control and use the three location sliders to navigate the 2D cutplane inside the structure:

Before you continue with the Parameterization section, open the global mesh properties dialog box by selecting Mesh $\Rightarrow$ Global Mesh Properties ( ) and switch back to the hexahedral mesh. Confirm the question of whether results should be deleted with OK. In case the cut plane is still active, reenter the cutting plane dialog box an switch it off (View $\Rightarrow$ Cutting plane, ).

**Parameterization**

One of the most powerful features of CST EM STUDIO™ is the parameterization ability. This means that you can define variables and use them, for instance, for the definition of a solid. The solver contains the option to vary parameters within a user-defined range. One-dimensional results will be summarized in tables and can be plotted as a function of the varied parameters.

Because this tutorial deals with a rotary encoder, the angle of rotation between the top and the bottom yoke will be parameterized. Therefore, select the top yoke and enter the transformation dialog box (Objects $\Rightarrow$ Transform Shape, ). Select the Operation
"Rotate" and enter the parameter's name (e.g. "angle") with a minus sign into the rotate field around the Z-axis:

After checking your settings with the Preview button, leave the dialog box by pressing the OK button. Because you are now going to change the structure, the previously calculated results will no longer match the current structure. If results are present, the following dialog box appears:

Here you may specify whether to store the old model together with its results in a cache, store as a new file, or just delete the current results. In this case you should simply accept the default choice and press OK. After results have been removed, the next dialog box opens and prompts you to enter a valid value for the new variable:
Set its value to 10 and enter a helpful description text before confirming with OK. The recently defined parameter appears inside the Parameter List window. This window is usually docked at the lower left part of the user interface:

To start the parameter sweep, first enter the magnetostatic solver dialog box (Solve \( \Rightarrow \) M-Static Solver). Make certain that the “Hexahedral” mesh type is selected and press the Par. Sweep button to open the parameter sweep dialog box:
To add a new watch, select Field from the Result watch dropdown list. A dialog box appears where you should select the type of the field, its component and its position. In this case, the Z-component of the B-Field has to be monitored at the position $X = 0$, $Y = 17.5$, $Z = 10.5$.

After you confirm the settings with OK, the dialog box closes and the new watch will be added to the result watch list in the parameter sweep dialog box. The next step is to define a new parameter sequence for this watch. After pressing the New seq. button, you can add a new parameter to this sequence by selecting the New par. button:
A new dialog box appears and you can select the previously defined parameter Name from a list. Check the Sweep box and enter a range From 0 To 40 with 5 Samples. After confirming with OK, the parameter sweep dialog box should appear as follows:

Now the calculation sequence can be started with the Start button. The progress bar in the lower left corner gives you some information about the current calculation run:

After the sweep has finished, you can check the logfile if each calculation was completed successfully. Press the View logfile button and check the run’s summaries:
Both the result dialog box and parameter sweep dialog box can be dismissed with the OK or Close buttons. Finally, you can examine the result of the parameter sweep by selecting NT ⇒ Tables ⇒ B-Field (Z) (0, 17.5, 10.5):

![Diagram](image)

The diagram shows the variation of the B-field inside the Hall sensor versus the rotation angle of the sensor.
Parameter Sweep with the Tetrahedral Meshing Method

Before restarting the parameter sweep with the tetrahedral mesh method, it is advisable to copy the previously created result curve to a new folder, to allow for an easy comparison between the two methods.

First, select the 1D Results folder in the navigation tree: NT (Navigation Tree) ⇒ 1D Results, then create a new tree folder by selecting Edit ⇒ Add new tree folder:

Enter an appropriate name (e.g. “Compare”) and press Enter. To copy the parameter sweep result curve (NT ⇒ Tables ⇒ B-Field (Z) (0, 17.5, 10.5)), select its icon and activate Edit ⇒ Copy Result Curve(s). Afterwards, select the previously created folder “Compare” and paste a copy of the result curve into this folder, by choosing Edit ⇒ Paste Result Curve(s):

Now select the newly created item and rename it via Edit ⇒ Rename (F2):

A meaningful and short name is simply “HEX”. These operations are also accessible via the context sensitive menu or by shortcuts. Here is a summary of the complete workflow:

1. Select Navigation Tree ⇒ 1D Results
2. Create a new folder (Edit ⇒ Add new tree folder) and name it “Compare”
3. Select the curve to be copied.
4. Choose the copy operation: Edit ⇒ Copy Result Curve(s) / Ctrl + C
5. Select the previously created folder.
6. Paste the curve to be copied: Edit ⇒ Paste Result Curve(s) / Ctrl + V
7. Rename the new curve: Edit ⇒ Rename / F2

After saving the hexahedral result curve you can continue to start the tetrahedral parameter sweep. Instead of entering the global mesh properties dialog box, go directly to the magnetostatic solver dialog box and switch to the tetrahedral meshing type:
To open the parameter sweep dialog box again, press the Par. Sweep... button. At this point old results will be deleted, when present. When you are prompted by a dialog box Results May Become..., confirm the deletion of results. Remember that you already saved the 1D curve from the last parameter sweep in a non-deletable folder. Without any further changes you should start the parameter sweep again.

After all calculations have been completed, you should take a short look at the logfile (Results → View Logfiles → Parameter Sweep Logfile):

Both the result dialog box and the parameter sweep dialog box can be closed with the OK or Close buttons. To compare the new result curve with the old one, perform the following steps:
1. Select the curve to be copied \((NT \Rightarrow \text{Tables} \Rightarrow \text{B-Field (Z)} (0, 17.5, 10.5))\).
2. Choose the copy operation: \(Edit \Rightarrow \text{Copy Result Curve(s)} / \text{Ctrl} + C\)
3. Select the “1D Results \Rightarrow \text{Compare}” folder.
4. Paste the curve to be copied: \(Edit \Rightarrow \text{Paste Result Curve(s)} / \text{Ctrl} + V\)
5. Rename the new curve: \(Edit \Rightarrow \text{Rename} / \text{F2} \) (e.g. “TET”)

If you select the folder with the copied curves, both will be plotted in one diagram:

![Graph showing comparison between HEX and TET curves]

Obviously, a small gap is present between the curves (approximately 5% difference). This difference results from the meshing methods producing different errors and therefore different results. This difference reduces significantly after the meshes for both methods are refined. In addition to the mesh adaptation feature (introduced in the next chapter), the availability of two different meshing methods offers a powerful alternative to validate simulation results.

### Accuracy Considerations

A static field calculation is mainly affected by two sources of numerical inaccuracies:

1. Numerical errors introduced by the iterative linear equation system solver.
2. Inaccuracies arising from the finite mesh resolution.

In the following section we provide some hints how to minimize these errors and achieve highly accurate results.

- Numerical errors introduced by the iterative linear equation system solver.

CST EM STUDIO™ uses an iterative linear equation system solver to solve the discretized field problem. This means that the iterative solver will stop a calculation if a given accuracy has been reached. In general, the accuracy setting of 1e-4 is sufficient for
most calculations. However, in some cases the solver will give you a warning that the results are inaccurate and that you should consider increasing the solver accuracy.

- Inaccuracies arising from the finite mesh resolution.

Inaccuracies arising from the finite mesh resolution are usually more difficult to estimate. The only way to ensure the accuracy of the solution is to increase the mesh resolution and recalculate the results. When they no longer significantly change when the mesh density is increased, then convergence has been achieved.

In the example above, a modified default mesh has been used. The easiest way to test the accuracy of the results is to use the fully automatic mesh adaption that can be switched on by checking the Adaptive mesh refinement option in the solver control dialog box (Solve ⇒ M-Static Solver, ...

Before activating the adaptive mesh refinement tool, set the solver Accuracy limit to 1e-6. This is necessary because the adaptive refined problems start to deliver inaccurate results with an accuracy setting of “1e-4”. Finally, start the solver again by pressing the Start button. Please keep in mind that the calculation is performed for only one parameter setting (angle = 10). After the mesh adaption procedure has completed, you can visualize the energy deviation for two subsequent passes by selecting 1D Results ⇒ Adaptive Meshing ⇒ Error from the navigation tree:
As evident in the above plot, the maximum energy deviation is below 1% between the first and the second pass, indicating that the accuracy of the first calculation was already sufficient. If you view the energy curve (Results ⇒ Adaptive Meshing ⇒ Energy), you can watch the energy values vary from pass to pass.

The deviation between first and the second runs is approximately 1%. In many cases, global results like energies are less susceptible to discretization errors than local results such as field values at certain positions.
Getting More Information

Congratulations! You have just completed the Magnetostatic sensor tutorial that should have provided you with a good working knowledge on how to use the magnetostatic solver. The following topics have been covered:

1. General modeling considerations, using templates, etc.
2. Model a cylindrical structure by using the cylinder-, rotation- and transformation tools.
3. Define a permanent magnet.
4. Define boundary conditions.
5. Apply changes to the automatically generated mesh.
6. Start the magnetostatic solver.
7. Visualize the magnetic fields.
8. Run the Magnetostatic solver with the tetrahedral meshing method.
9. Perform a parameter sweep with hexahedral and tetrahedral meshes.
10. Obtain accurate and converged results using the automatic mesh adaption.

You can obtain more information on each particular step from the online help system that can be activated either by pressing the Help button in each dialog box or by pressing the F1 key at any time to obtain context sensitive information.

In some instances, we have referred to the CST EM STUDIO™ Getting Started manual that is also a good source of information for general topics.

In addition to this tutorial, you can find additional magnetostatic calculation examples in the “Examples” folder in your installation directory. Each of these examples contains a Readme item in the navigation tree that will give you some more information about the particular device.

And last but not least: Please also visit one of the training classes, held regularly at a location near you. Thank you for using CST EM STUDIO™!
The Magnetostatic Force Tutorial

Geometric Construction and Solver Settings 90

Introduction and Model's Dimensions 90
Geometric Construction Steps 90
Solver Settings 105

Results 111

Parameterization 112

Accuracy considerations 117

Getting More Information 119
Geometric Construction and Solver Settings

Introduction and Model’s Dimensions

In this tutorial you will run a magnetostatic simulation with a subsequent force calculation. The examined model is a linear motor consisting of two coils, two iron yokes and a permanent magnet. The yokes form a magnetic circuit that is driven by coils with currents of opposing polarity. A current-dependent force is then exerted on a movable permanent magnet located between the yokes. After construction steps have been completed, you will perform the necessary solver settings and perform a first simulation. Finally, the force calculation and the parameter sweep feature are used to check the linearity of the device.

We strongly suggest that you carefully read through the CST EM STUDIO™ Getting Started manual before starting this tutorial.

Geometric Construction Steps

☑ Select a Template

After you start CST DESIGN ENVIRONMENT™ and choose to create a new CST EM STUDIO™ project, you are requested to select a template that best fits your current device. Here the “Magnetostatic” template should be chosen.
This template automatically sets the dimensions unit to mm, the background material to “Normal” and all boundaries to be of type “electric.”

□ Define background properties

Because the structure will be defined in a vacuum background, you must define the size of the surrounding empty space. Therefore, select Solve → Background Material ((clicked image)) to enter the background material dialog box:
For this example, a distance of 10 mm to the calculation domain’s boundaries has to be set for each direction. To define the distance only once, check the button **Apply in all directions** and enter a value of 10 in the **Distance** field. Confirm your settings by pressing the **OK** button.

☐ Define Working Plane Properties

The next step will usually be to set the working plane properties in order to make the drawing plane large enough for your device. Because the structure has a maximum extension of 120 mm along a coordinate direction, the working plane size should be set to at least 120 mm. These settings can be changed in a dialog box that opens after selecting **Edit → Working Plane Properties** from the main menu. Please note that we will use the same document conventions here as they have been introduced in the **Getting Started** manual.
Change the settings in the working plane properties window to the values given above. Furthermore, uncheck the *Auto* and *Snap* checkboxes for both raster settings before pressing the *OK* button.

□  **Yoke**

The first step for the linear motor is the construction of the first yoke. For this purpose, the extrude tool must first be used. Please activate the extrusion mode now (*Objects ➤ Extrude,* \*\*). When you are prompted to pick the first polygon point, you can also enter the coordinates numerically by pressing the *Tab* key that will open the following dialog box:

In this case, you should enter 9 points defining the polygon that will be extruded to form the first yoke. Please enter the first point’s coordinates as $X = 0.5$ and $Y = 8$ in the dialog box and press the *OK* button.

Afterwards, you can repeat these steps for the second point:

1. Press the *Tab* key
2. Enter $X = 0.5$, $Y = 20$ in the dialog box and press *OK*

Repeat this procedure for all points from the following list:

<table>
<thead>
<tr>
<th>Number</th>
<th>X</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0.5</td>
<td>8</td>
</tr>
<tr>
<td>2</td>
<td>0.5</td>
<td>20</td>
</tr>
<tr>
<td>3</td>
<td>60</td>
<td>20</td>
</tr>
<tr>
<td>4</td>
<td>60</td>
<td>-20</td>
</tr>
<tr>
<td>5</td>
<td>0.5</td>
<td>-20</td>
</tr>
<tr>
<td>6</td>
<td>0.5</td>
<td>-8</td>
</tr>
<tr>
<td>7</td>
<td>48</td>
<td>-8</td>
</tr>
<tr>
<td>8</td>
<td>48</td>
<td>8</td>
</tr>
<tr>
<td>9</td>
<td>0.5</td>
<td>8</td>
</tr>
</tbody>
</table>

After you have entered the last point, you will be requested to enter the height of the extrude body.
This can also be accomplished numerically by pressing the *Tab* key again, entering the *Height* of 12 and pressing the *OK* button. Now the following dialog box will appear, displaying a summary of your previous input:

![Extrude Profile Dialog Box]

Please check all these settings carefully. If you encounter any mistakes, please change the value in the corresponding entry field. You should now assign a meaningful name to the extrude body by entering e.g. “yoke1” in the *Name* field.

Finally, you need to define the yoke’s material. Because no material has yet been defined for the yoke, you should open the material definition dialog box by selecting *New Material…* from the Material drop down list:
In this dialog box you should define a new Material name (e.g. Iron-1000) and set the Type to a Normal material. Afterwards, specify the material properties in the Epsilon and Mue fields. Here you only need to change the permeability constant Mue to 1000. Finally, choose a color for the material by pressing the Change button. Your dialog box should now look similar to the above picture before you press the OK button.

Back in the extrude creation dialog box you can also press the OK button to create the first yoke. Your screen should now appear as follows (you can press the Space key in order to zoom the structure to the maximum possible extent):
Define the Second Yoke

The next construction step deals with the definition of the second yoke using the transform tool. Select the first yoke by double-clicking on it or selecting its tree item in the navigation tree. Afterwards, activate the transform dialog box by selecting Objects ➤ Transform Shape (≡):

![Transform Selected Object dialog box](image)
Select the *Mirror* operation and enter an X-value of 1 for the mirror plane normal. To create a transformed copy of the first yoke, check the *Copy* box. After you have checked your settings, you might use the *Preview* button to obtain a graphical feedback for your input:

Finally, if all settings are correct, create the second yoke with the *OK* button.

To change the name of the second yoke, select its item in the navigation tree and select *Edit* ⇒ *Rename* (F2). Now the item text inside the tree becomes editable and you should assign a more suitable name to the new solid (e.g. “yoke2”).

Create the Permanent Magnet

The geometric definition of the permanent magnet can be easily accomplished with the brick tool. Please activate the brick creation mode now (*Objects* ⇒ *Basic Shapes* ⇒ *Brick, ✓*). You will be asked to enter the first point of the base rectangle. Similar to the extrude tool, you may enter the values with the mouse by making a double-click at the desired position, or numerically by pressing the *Tab* key. In this case, choose the second option and press *Tab* to open the *Enter Point* dialog box:

Enter the point’s coordinates as X = -20 and Y = -7.5 and confirm your settings with *OK*. The second point will be created analogously:

1. Press *Tab*
2. Enter $X = 20$, $Y = 7.5$ in the dialog box and press *OK*

Lastly you will be asked to enter the brick’s height:
1. Press Tab
2. Enter a height of 12 in the dialog box and press OK

Now the brick dialog box appears, where you should check your settings and assign a name to the brick (e.g. “magnet”). Before you create the brick, you need to define a new material for the magnet's material. Therefore, select New Material... from the material drop down list to enter the material dialog box again:

![New Material Parameters dialog box](image)

The magnet will be made of Normal material with Epsilon and Mu values of 1. Choose an appropriate name (e.g. “magnet material”) and color for the new material and leave the dialog box by pressing the OK button. Now you will return to the brick dialog box:
Take a final look at the settings before you leave the dialog box with the OK button.

The next step is to define the permanent magnet’s magnetization vector. Therefore, activate the permanent magnet tool by selecting Solve ⇒ Permanent Magnet ( ). Now you will be asked to select the magnet’s surface with a double-click. Move the mouse cursor to the previously defined brick and select it with a double-click. The selected surface will be highlighted red and a dialog box will open where you should define the magnet’s properties:

Enter 0.2 for the y-component of the magnetization vector. Pressing the Preview button shows you the orientation of the current magnetization vector.
To store your settings, press OK. The permanent magnet definition can always be reviewed by selecting its icon in the navigation tree NT ⇒ Permanent Magnets.

Create the Coils

The final step in the construction process of the linear motor is the creation of the two coils. The coil’s dimensions are defined by a profile curve and a path curve. Therefore, you must define curves before you activate the coil tool. Create a new curve by selecting Curves ⇒ New Curve (\(\mathbb{R}\)). After the new curve item appears in the Curves folder of the navigation tree, you can create the coil’s profile by selecting the rectangle tool (Curves ⇒ Rectangle (\(\mathbb{R}\))). Now you will be requested to enter the rectangle’s first point; press the Tab key for numerical input:

Set the X value to 40 and the Y value to –8 and confirm with OK. The second point will be entered in the same manner:

1. Press Tab
2. Enter \(X = 48, \ Y = 8\) in the dialog box and press OK

Before the rectangle is finally created, the associated dialog box opens:
Check your settings and confirm with the OK button (you do not have to change the name because the rectangle will be deleted during the coil’s creation).

To define the path curve you have to activate the working coordinate system (WCS) by selecting \( \text{WCS} \Rightarrow \text{Local Coordinate System} (e_u) \). After its activation, the WCS is still aligned with the global coordinate system. In this case, the WCS has to be rotated around the \( u \)-axis by +90 degrees. Therefore, select \( \text{WCS} \Rightarrow \text{Rotate } +90^\circ \text{ around } u\)-axis (or press \text{Shift} + \text{u}):
Everything has now been set up to create the coil’s path curve. Select the rectangle tool again (Curves $\Rightarrow$ Rectangle ($\square$)) and perform the following steps:

1. Press Tab
2. Enter $U = 47$, $V = -1$ in the dialog box and press OK
3. Press Tab
4. Enter $U = 61$, $V = 13$ in the dialog box and press OK

The rectangle dialog box opens again to allow you to check your settings:

Confirm the settings by pressing the OK button.
Now it is time to define the first coil. Select Solve $\Rightarrow$ Current Coil from Curves (②) to activate the coil mode. Now you will be requested to select the coil’s profile curve. Select profile curve (shown in the above picture) with a double-click. Next, you should select the coil’s path curve with a double-click to open the coil dialog box with a preview:

![Diagram of coil dialog box]

Enter a current of 0.1 A, the number of turns as 1000 and select Vacuum as coil material before you create the coil with OK.
To create the second coil, simply select the previously defined coil and activate the transform dialog box by selecting Objects ⇒ Transform Shape (\(d^T\)):

Set the operation type to “Mirror” and its plane normal to \(U = 1\). To create a transformed copy of the coil, check the Copy checkbox. After you have performed the setting with the OK button the view should look like this (use the Space key to zoom to the structure’s maximum possible extent):

Finally, change the name of the second coil as done before with the yoke. Select its item in the navigation tree and choose Edit ⇒ Rename (F2) to make the tree item editable. Enter an appropriate name (e.g. “coil2”) and confirm by pressing the Enter key.

Congratulations! The geometric construction is now completed. Before the simulation can be started, however, several solver settings must be applied.
Solver Settings

Define Boundary Conditions and Symmetry Settings

The calculation domain is covered and terminated by six faces, each of which must be assigned a boundary condition. In fact, the influence of the boundary conditions for this calculation is rather small because the magnetic flux density is mainly focused inside the iron core of the structure. However, as previously mentioned, the structure is embedded in a vacuum atmosphere and therefore all boundary conditions should be set to type “open”. The magnetostatics template has set the boundary conditions to be “electric” so you need to change these to type “open”. Enter the boundary conditions dialog box by selecting Solve → Boundary Conditions ( ). You will recognize that the modeler view also shows the currently set boundary conditions:

![Boundary Conditions dialog box]

Obviously, the structure is symmetric to the XY- and XZ-planes. To save simulation time you can define symmetry conditions that need to suit the field inside these planes.
Please click on the *Symmetry Planes* tab in the *Boundary Conditions* dialog box to set the symmetry of the XZ’s plane to be “magnetic” and the XY’s symmetry to be of type “electric”.

The magnetic boundary condition sets the tangential component of the magnetic field to zero; it behaves like a perfect magnetic conductor (PMC). In contrast, the electric boundary forces the normal component of the magnetic flux density to be zero; it appears to be like a perfect electrical conductor (PEC). The table below shows the conditions for different field types at these boundary / symmetry conditions:

<table>
<thead>
<tr>
<th></th>
<th>Magnetic boundary</th>
<th>Electric boundary</th>
</tr>
</thead>
<tbody>
<tr>
<td>Electric field / flux</td>
<td>D-normal = 0</td>
<td>E-tangential = 0</td>
</tr>
<tr>
<td>Magnetic field / flux</td>
<td>H-tangential = 0</td>
<td>B-normal = 0</td>
</tr>
<tr>
<td>Stationary current</td>
<td>J-normal = 0</td>
<td>J-tangential = 0</td>
</tr>
</tbody>
</table>

As soon as you enter the *Symmetry Planes* tab, the *Modeler View* changes to display the currently set symmetry planes:
The blue-framed plane indicates a magnetic and the green-framed plane an electric symmetry setting in the screenshot above. Finally close the dialog box with the OK button.

Disclaimer: Please note that setting the XZ’s symmetry plane will cut the calculation domain parallel to the coil windings. This may cause minor differences to calculations without symmetry planes because the internal representation of the current paths inside the coil will change slightly.

Mesh Adjustment

For the numerical solution of a field problem, it is necessary to discretize its calculation domain. This means that the volume will be subdivided, or in other terms, that a mesh will be placed on the structure. CST EM STUDIO™ automatically generates a calculation mesh that can be modified by the user in many ways.

To take a first look at the automatically generated mesh, activate the Mesh view by selecting Mesh $\Rightarrow$ Mesh View ( ).
The picture above shows the z-meshing plane at z-position = 6, i.e. the first meshed plane in z-direction. You can obtain the same view if you activate the z-meshing plane by clicking on the button or by just typing Z in the Mesh View. You can use the tools on the grid toolbar to switch to another mesh plane normal ( ) or to vary the displayed mesh plane ( ).

In this case, the automatically generated mesh is still quite coarse at the air gap between the yokes and the magnet. To get accurate results, it is necessary to refine the mesh inside the air gaps. A finer mesh leads to a more accurate field calculation inside the gaps and increases the accuracy of the subsequent force computation.

To refine the mesh inside the air gaps, select yoke1 and open the mesh properties dialog box by choosing Edit ⇒ Mesh Properties… (also accessible with a double-click when the mesh view is active):

Because the mesh needs to be refined in the yoke’s surroundings, you need to specify an edge refinement factor that allows a better sampling of the air gaps. Activate the local edge refinement by marking the checkbox and set the edge refinement to a value of 30.

Please note that this high refinement factor only takes effect because the Mesh Line Ratio Limit inside the global mesh properties dialog box has been set to a very high value of 50 by the magnetostatics template. After confirming with OK you can apply the same procedure to the second yoke. Examination of the mesh reveals that the transitions between the yokes and the surrounding air have been refined:
Obviously, the mesh is now strongly refined within the gap areas of the structure. Finally, leave the Mesh View by toggling the button or un-checking Mesh View from the main menu.

☐ Start the Solver and Calculate Forces

The solver parameters are specified in the magnetostatic solver control dialog box that can be opened by selecting Solve → M-Static Solver from the main menu or by pressing the corresponding icon in the toolbar. Please ensure that the accuracy setting is set to $1e^{-4}$.

Now start the magnetostatic field calculation by pressing the Start button. The progress bar in the lower left corner of the main window displays information about the calculation status:
Now that CST EM STUDIO™ has calculated the magnetic field and magnet flux density, the force on the magnet can be calculated. Therefore, switch back to the global WCS and open the Calculate Forces and Torques dialog box by selecting Results ➪ Force Calculation... from the main menu.

Because we are not interested in any torques here, just press the Calculate button to start the force calculation. The forces on all solids will now be calculated. After the calculation has finished, a result window opens automatically containing forces and torques on every solid. To close this window, press the OK button.

This window can be reopened at any time by selecting Navigation Tree ➪ MForces.
Results

Congratulations, you have simulated the linear motor! Let's examine the calculated fields. You will notice that some new entries have appeared in the Navigation Tree:

As mentioned above, this tutorial focuses on the force applied to the magnet. In addition, the magnetic field and the flux density are available. The following screenshot shows the magnetic flux density distribution in the entire calculation domain. Due to the magnetization of the permanent magnet, the flux density is significantly larger in the right yoke than in the left one.

This plot gives you a first impression about the fields in and around the magnetic circuit. For a more detailed analysis, activate the 2D plot in a plane by selecting Results \(\Rightarrow\) 3D Fields on 2D Plane:
It is always possible to modify plot settings. Therefore, click Results -> Plot Properties… to open the plot properties dialog box. For more information on this subject please refer to the Online Help.

Parameterization

One of the most advanced features of CST EM STUDIO™ is the parameterization ability. This means that you can define variables and use them, for instance, for the definition of a solid. The solver contains the option to vary parameters within a user-defined range. 1D Results will be summarized in tables and can be plotted as a function of the varied parameters.

Because a linear dependency between the force on the magnet and the coil driving currents is desired, the following study will focus on this aspect. Therefore, the current definitions for the coils, made in the previous chapter, will be controlled by a parameter. Select the first coil item in the navigation tree and press Edit -> Coil Current/Turns… to open the coil dialog box and replace the current value with a new variable (e.g. “current”):

After confirming with the OK button, the following dialog box appears:

Because you are now going to change the structure, the previously calculated results will no longer match the current structure. Here, you may specify whether the old model will
be stored together with its results in the cache, stored as a new file, or deleted. In this case you should simply accept the default choice and press OK.

After results have been removed, the next dialog box opens asking you to enter a valid value for the new variable:

Set its value to 0.1 and enter a helpful description text before confirming with OK.

The recently defined parameter appears inside the Parameter List window. This window is usually docked at the lower left part of the main window:

Apply the same steps to the second coil to change its current definition:

1. Select the second coil in the navigation tree
2. Open the coil dialog by selecting Edit ➔ Coil Current/Turns…
3. Replace the old current definition by the name of the previously defined variable “current”.
4. Perform the change with the OK button

To start the parameter sweep, enter the magnetostatic solver dialog box first (Solve ➔ M-Static Solver (in)). Press the Par. Sweep button to get to the parameter sweep dialog box:
To add a new watch, select Force… from the Result watch dropdown list. The definition of the force watch requires some settings in the upcoming dialog box.

First, you should select the magnet from the Solidname drop down list (component1:magnet). Then, select the Component of the magnet’s force. Because the magnet can be moved in the X-direction you can leave the default at X and store the watch by closing the dialog box with OK.
The next step is to define a new parameter sequence for this watch. After pressing the New seq. button, you can add a new parameter to this sequence by selecting the New par. button:

![Parameter Sweep Parameter](image)

A new dialog box appears and you can select the previously defined parameter name from a dropdown list. Check the Sweep box and enter a range from 0 to 1 with 6 steps. After confirming with OK, the parameter sweep dialog box should look as follows:

![Parameter Sweep](image)

Now the calculation sequence can be initiated with the Start button. The progress bar in the lower left corner provides information about the current calculation run:

![Progress Bar](image)

After the sweep has finished, you can check the logfile to determine if each calculation has been completed successfully. Press the View logfile button and check all runs’ summaries:

![Logfile](image)
Both the result dialog box and parameter sweep dialog box can be terminated with the OK / Close buttons. Finally, you can examine the result of the parameter sweep by selecting NT (Navigation Tree) ⇒ Tables ⇒ Force (component1) (magnet) [X]:

The force on the magnet has a linear dependency on the current inside the coils.
Accuracy considerations

A static field calculation is mainly affected by two sources of numerical inaccuracies:

1. Numerical errors introduced by the iterative linear equation system solver.
2. Inaccuracies arising from the finite mesh resolution.

In the following section we provide hints on how to minimize these errors and achieve highly accurate results.

- Numerical errors introduced by the iterative linear equation system solver.

CST EM STUDIO™ uses an iterative linear equation system solver to solve the discretized field problem. This means that the iterative solver will stop a calculation if a given accuracy has been reached. In most cases, an accuracy setting of 1e-4 is sufficient. However, for some problems with very high material or mesh ratios, the solver will give you a warning that some results are inaccurate and that you should consider increasing the solver accuracy.

- Inaccuracies arising from the finite mesh resolution.

Inaccuracies arising from the finite mesh resolution are usually more difficult to estimate. The only way to ensure the accuracy of the solution is to increase the mesh resolution and recalculate the results. When they no longer significantly change as the mesh density is increased, then convergence has been achieved.

In the example above, you have used a modified default mesh. The easiest way to test the accuracy of the results is to use fully automatic mesh adaption that can be switched on by checking the Adaptive mesh refinement option in the solver control dialog box (Solve ⇒ M-Static Solver (link)). Improve the Accuracy setting to a value of 1e-6 to avoid numerical problems:

![Magnetostatic Solver Parameters](image)

After activating the adaptive mesh refinement tool, you should start the solver again by pressing the Start button. After the mesh adaption procedure has finished, you can
visualize the energy error for two subsequent passes by selecting 1D Results ⊛ Adaptive Meshing ⊛ Error from the navigation tree:

Within 2 passes the mesh adaption was able to reduce the energy error below the requested limit. As you can see, the maximum energy deviation between the first and second passes is already below 0.5%, indicating that the calculation with the first mesh produced quite accurate results. A final look on the forces calculated with the adapted mesh shows that the force deviation on the magnet is also below 0.5% (the force on the magnet calculated in the initial run was 0.38335 N).
Getting More Information

Congratulations! You have just completed the linear motor tutorial that should have provided you with a good working knowledge on how to use the magnetostatics solver. The following topics have been covered:

1. General modeling considerations, using templates, etc.
2. Model a linear motor by using the extrude, the brick and the transformation tool.
3. Define a permanent magnet.
4. Define coils.
5. Define boundary and symmetry conditions.
6. Modify the automatically generated mesh.
7. Start the magnetostatics solver.
8. Visualize the magnetic fields.
9. Use the force calculation.
10. Perform a parameter sweep.
11. Obtain accurate and converged results using the automatic mesh adaption.

You can obtain more information for each particular step from the online help system that can be activated either by pressing the Help button in each dialog box or by pressing the F1 key at any time to obtain context sensitive information.

In some instances we have referred to the Getting Started manual that is also a good source of information for general topics.

In addition to this tutorial, you can find additional magnetostatic calculation examples in the “examples” folder in your installation directory. Each of these examples contains a Readme item in the navigation tree that will give you more information about the particular device.

And last but not least: Please also visit one of the training classes regularly held at a location near you. Thank you for using CST EM STUDIO™!
Geometric Construction and Solver Settings

Introduction and Model Dimensions

In this tutorial, you will perform a stationary current simulation and a subsequent magnetostatic field calculation. The geometry to be examined is a circuit breaker consisting of two contact springs connected by a bridge. The contact springs will be constructed using the line and arc curve tools. The resulting curve can then be traced to form a solid. On both sides of the contact area a gold pad is associated that can be constructed with the extrusion tool. For the construction of the bridge, a local coordinate system is employed to make creation of the brick easier.

One matter of concern is the current flow from one contact over the bridge to the other contact. Therefore, two current ports are defined for the stationary current solver. After the solver run, the fields are visualized and then used as a source field for a subsequent magnetostatic calculation.

We strongly recommend that you carefully read through the CST EM STUDIO™ Getting Started manual before starting this tutorial.

All dimensions in the detail drawing are given in cm.

Geometric Construction Steps

☐ Select a Template

Once you have started the CST DESIGN ENVIROMENT™ and have chosen to create a new CST EM STUDIO™ project, you are requested to select a template that best fits your current device. Here, the “Stationary Currents” template should be chosen.
This template automatically sets the units to mm, the background material to “normal” and all boundaries to type “electric.”

☐ Set Units

The circuit breaker device in this tutorial has dimensions given in cm. Therefore, you should adjust the units settings to avoid manually converting the geometric dimensions. Open the units dialog **Solve ⇒ Units** and change the dimensions to **cm**.
Define background properties

Because the structure will be defined in a vacuum background, you must define the size of the surrounding empty space. Therefore, select Solve \( \Rightarrow \) Background Material (2) to enter the background material dialog:

![Background Properties dialog]

For this example, enter 2 cm for the Lower Y, Upper Y, Lower Z and Upper Z distance and confirm by pressing the OK button. No space is added for X-distances because the circuit breaker needs to touch the boundaries in order to correctly apply the current port-sources in a later step.

Define the first curve element of the right contact

The first step for the circuit breaker is the construction of the right contact. Since the construction uses the curve tool with the trace function, a new curve has to be generated. Therefore, simply press the corresponding icon from the toolbar (3) or select Curves \( \Rightarrow \) New Curve from the menu. Then, define the first line with the curve line tool Curves \( \Rightarrow \) Line (4). Double-click on the working plane the point x=5, y=2 for the first point and x=2, y=2 for the second. After the definition, a dialog box displays your settings:
Define the arc of the right contact

For the next part of the curve, the arc tool will be used. Choose Curves $\Rightarrow$ Arc (Q) and input the arc center $x = 2$, $y = 1$ with a double-click on the working plane's coordinate. Instead of picking the correct position on the working plane, you may alternatively enter the point’s coordinates numerically by opening the point dialog box with the Tab key:
To complete the arc, the start and end points must also be defined. As before, double-click on the corresponding coordinates on the working plane:

<table>
<thead>
<tr>
<th>Point</th>
<th>X</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start point</td>
<td>2</td>
<td>0</td>
</tr>
<tr>
<td>End Point</td>
<td>2</td>
<td>2</td>
</tr>
</tbody>
</table>

Alternatively, you can use the pick tools to enter the start point: Simply activate the pick point tool $\text{Objects } \Rightarrow \text{Pick } \Rightarrow \text{Pick Point}$ (shortcut: $p$) and select the end point of the previously constructed line.

Please check your input against the given screenshot and make sure the arc is oriented correctly, otherwise you can change the arc’s orientation in the dialog box. If all settings are correct, press OK to define the arc.
Define the last curve line of the right contact

The last curve element is another line and can be created similar to the first one. Activate the curve line tool Curves ⇔ Line (•.) and enter the points \( x = 2, y = 0 \) and \( x = 3, y = 0 \). Finally, double-check your input numerically in the dialog box and confirm with OK. The screenshot below shows the current model status; compare it with your model for possible construction mistakes.

Trace Curve

After defining the contact as a curve, it has to be transformed into a solid. The right tool for this procedure is the Trace from Curve tool. Choose Curves ⇔ Trace from Curves (□) and double-click on any curve element when asked for the curve. Before the trace can be created, a new material must be defined: Select “[New Material...]” from the Material drop-down list in the trace definition dialog box that appears after double-clicking on the curve.
The material “copper” can then be defined. This requires changing the name to “copper”, selecting a new color (Change) and inputting an electric conductivity of 5.8e7 S/m at the conductivity Tab.

Please note: The defined material “copper” will be available inside the current project for the further creation of other solids. However, if you want to save this specific material definition for use in other projects, you may check the button Add to material library. You will have access to this material database by clicking on Load from Material Library in the Materials context menu in the navigation tree.

Pressing the OK button stores the material and closes the dialog so that you can continue to enter the trace parameters.

Back in the trace creation dialog box, please check that the Material has changed to copper. Enter “contact spring” in the Name field. Further settings are: Thickness =1, Width = 0.2 and Rounded Caps at the End.
Please note that the end of the curve depends on which part of the curve you chose for the trace action. This fact must be considered in the construction, so you should ensure that the preview of the shape has a rounded cap at the shorter end. If not, it is only necessary to switch off the *Rounded caps* at the *End* and enable them at the *Start* of the curve.

Use the *Preview* button to cross-check the other settings with the given screenshot and finally close the dialog box with *OK*.

Define the contact pad

To complete the construction of the right contact, the definition of a contact pad is still required. This task is easily done by extruding the bottom face of the spring.
To perform the extrusion, the desired face must be chosen beforehand. Therefore, activate the pick face tool with Objects \( \Rightarrow \) Pick \( \Rightarrow \) Pick Face (shortcut: f.) and double-click on the bottom face of the spring (see screenshot). Then choose the extrude tool Objects \( \Rightarrow \) Extrude ( ) that opens a dialog box for the extrusion parameters. First, a new material has to be defined because the contact pad is composed of gold. Choose ["New Material..."] from the Material drop-down list.

The definition of gold requires changing the Material name to “gold”, setting Type to “Normal”, selecting a new color (Change) and inputting an electric conductivity of 4.5e7 S/m in the Conductivity Tab. Store the material by pressing the OK button and continue with the extrusion.

Now that the new material has been defined, it should be automatically chosen as the material for the extrusion of the face. Please enter a name for the solid (“contact pad”) and 0.1 for the Height; the other parameters can be left at their default values. Because it is always recommended to verify the input by pressing the Preview button, you should first look at the preview:
Finally, confirm your settings with OK. You have just finished modeling the right contact. Due to the structure’s symmetry, the left contact can be produced by just one transform operation.

**Generation of the left contact by transformation**

Since both solids (spring and pad) belong to the same component, the left contact is easily generated by mirroring the complete group. To use the transform option, an object has to first be selected. Therefore, select “component1” in the navigation tree and choose *Objects ➔ Transform* (also available via the context menu):
In order to mirror the structure correctly, select Mirror as Operation, \( x = 1 \) as the Mirror plane normal and the Copy option as demonstrated in the screenshots below.

![Diagram of the mirrored structure]

After confirming with OK, two new shapes will appear in the navigation tree named as the transformation originals with "_1" added.

☐ Define the pads of bridge

After modeling the contact, the pads of the bridge must be constructed. Therefore, pick the previously defined pad of the contact at the bottom and extrude it again for the pad.

![Diagram of the extruded pad]

First, select Objects \( \Rightarrow \) Pick \( \Rightarrow \) Pick Face (shortcut: f) and double-click on the bottom face. Then the extrude tool can be activated by choosing Objects \( \Rightarrow \) Extrude. Enter a name ("bridge pad"), a value of 0.1 for the Height and choose "[New Component...]" from the Component drop-down list.

In view of the fact that the bridge is physically independent, it is preferable to construct it as a new component; this makes it subsequently easier to manipulate, e.g. for transformations.
Again, check your settings and confirm with OK.

Transform pad

As previously carried out for the contact, the bridge’s pad on the left side can be created with a mirror operation. This requires the newly created pad to be selected by double-clicking on it. Then choose Objects ⇒ Transform to start the transformation and repeat the previously made steps: Select mirror as Operation, set the Mirror plane normal to x=1 and activate the Copy option.
Construction of the bridge

The last modeling step is the construction of the bridge. To this point, the construction has been performed in the global coordinate system because no relative construction was needed. For proper parameterization it is advisable to define the bridge using a working coordinate system (WCS) that introduces a local coordinate system. For this tutorial the WCS will be aligned in the middle of the pads.

When working with the WCS, the first step is to switch the WCS on. This is accomplished by selecting **WCS → Local Coordinate System** (\(\text{Ctrl} \)). Once the WCS is activated it can be aligned to points, edges and faces.

Pick the two illustrated points with **Objects → Pick → Pick Point** (shortcut: \(\text{P}\)) and generate a new one with **Objects → Pick → Mean Last Two Points** (or context menu). Then align the WCS to this point by selecting **WCS → Align WCS with Selected Point** (shortcut: \(\text{W}\)).
With the WCS in the right location it is now quite easy to define the bridge. Therefore, activate the brick tool \textit{Objects \Rightarrow Basic Shapes \Rightarrow Brick (}) and enter the first point on the working plane ($u = -4$, $v = 0$). Continue the construction with the second point by again double-clicking on the coordinates in the working plane ($u = 4$, $v = -0.2$). In order to input the height (the third requested parameter), drag the rubber band until the displayed height equals $-1$ and again use the double-click to accept it. Remember that it is also possible to define the coordinates numerically by opening the point dialog box with the \textit{Tab} key. In the final dialog box you only have to enter a proper name, e.g. “bridge”, and choose “copper” from the \textit{Material} drop-down list.

![Brick dialog box](image)

Check your settings with the screenshot below by using the \textit{Preview} button:
Finally, create the brick with OK. As a result, the geometric modeling is complete and now the solver settings have to be established.

Solver Settings

- Define Boundary Conditions and Symmetry Settings

The calculation domain is covered and terminated by six faces. A boundary condition must be assigned to each of these faces.

Open the boundary dialog box by selecting Solve ⇒ Boundary Conditions ( ). For this example all boundaries need to be of type "electric". The electric boundary condition forces the electric fields and current-density fields to be normal at the calculation domain’s borders. The magnetic flux densities are tangential at this boundary condition. Because “electric” boundaries behave like perfect electric conductors they are able to carry surface currents; this fact is important for the subsequent magnetostatic calculation.
After checking the boundary conditions, you may define a symmetry condition for the XY plane. This will reduce the computation time by factor of 2, so symmetry conditions should always be defined, if possible. Because currents and electric fields will be tangential and magnetic fields will be normal to the XY plane, you must select a “magnetic” symmetry plane inside the Symmetry Planes tab:

Finally, leave the dialog by pressing the OK button.

Please note: The electric and magnetic boundary conditions must be used, especially for coupled problems between the stationary current solver and the magnetostatic solver. These correspond to a Perfect Electric Conductor (PEC) for the electric boundary condition and a Perfect Magnetic Conductor (PMC) in case of the magnetic boundary condition.
Definition of the current ports

Before the solver can be started, the driving sources need to be defined. In this tutorial, two current ports on both faces of the contact springs are necessary to feed the structure with a homogeneous distributed current density. Enter the current port definition mode with Solve ➤ Current Port () and click on the right face at the upper X-boundary (Face#1).

Once the position is defined via the face pick, the dialog opens and the Potential value of the port is requested:

Enter the value 0.05 for the Potential of the first port and confirm with OK. Then enter the current port definition mode Solve ➤ Current Port () again and pick face #2 at the lower X-boundary in order to define the second port. Enter a Potential value of -0.05 for this port:
Finish the source definition by pressing the OK button. Both faces, which are colored with the corresponding potential values, are shown after selecting the “Current ports” folder from the navigation tree.

☐ Adjust Mesh Properties

Before starting the solver, please observe the automatically generated mesh for the calculation. To activate the mesh, view select Mesh ⇒ Mesh View (¶). As evident after entering the mesh view, the default mesh is quite coarse:

For the circuit breaker tutorial, it is advisable to adjust the mesh properties. Therefore, select Mesh ⇒ Global Mesh Properties (¶) to open the corresponding dialog. In order to refine the mesh globally you only have to set the Lower mesh limit to 60.
Finally, confirm with OK and observe the mesh. Please note that this setting leads to a transverse spatial resolution of the conductor with 3 mesh cells, which is sufficient for this tutorial.
Start the stationary current solver

Finally, enter the stationary current solver dialog box Solve ⇒ Stationary Current Solver ( ). Because the resulting current density field will be used as a source field for a subsequent magnetostatic calculation, the solver accuracy should be chosen to be very accurate.

Thus, change the Accuracy to 1e-6 and start the solver with the Start button. After the solver is started, the progress is shown in the lower left corner of the main window:

Results

Congratulations, you have successfully simulated the circuit breaker! Let’s look at the calculated fields and resistance of the structure. You will notice that some new entries have appeared in the navigation tree:

Open the “2D/3D Results” folder from the navigation tree, select the “J-Field” folder and observe the current density:
For a closer examination, increase the number of plotted arrows accessible under Results ⇒ Plot Properties (or context menu). There, you can use the two sliders in the Objects frame to properly adjust the plot.

Please note that this setting has no influence on the accuracy of the calculated fields; it only influences the visualization.
Another result is the total loss-power inside the calculation domain. Because this result is just a number, it is shown in a text viewer that appears after selecting the icon from the navigation tree with a double-click (*NT ⇒ Loss Power*):

When all modeling steps match the problem specifications, the loss-power should be exactly equivalent to the value printed below:

\[ \text{Loss Power: 6.845812e+001 W} \]

Because the total voltage drop has been defined with the current ports, the resistor of the model can be calculated from the total *Loss Power*, \( P \):

\[ P = \frac{U^2}{R} \]

With \( U = 0.1 \) and a power of \( P = 6.8458e+001 \), the resistor calculates to:

\[ R = 1.460e-4 \]

The respective current value is derived as:
\[ I = \frac{P}{U} = \frac{U}{R} = 684.5812 \, A \]

This can be validated by observing the Current Port Parameter entry, also accessible via the navigation tree (NT ⇒ Current Port Parameter):

These values differ slightly from those derived from the loss-power; this results from the previously defined solver accuracy of 1e-6. To obtain a more precise solution, choose a better accuracy (e.g. 1e-12) and rerun the stationary current solver. This is done, of course, at the cost of a more time-consuming calculation.

After this introduction to the stationary current solver and its result types, the next chapter demonstrates how to use stationary current fields as a source type for a subsequent magnetostatic calculation

### Subsequent Magnetostatic Calculation

Because all boundary settings are also valid for the magnetostatic calculation, you can start this chapter by defining the source for the simulation run. The previously calculated current density field will be used.

- Define Current Field Source

Once the current density field has been calculated, you can define it as a source for the magnetostatic calculation. Select Solve ⇒ Stationary Current Field and enter a scaling Factor of 1 in the edit box.
This factor can be used to simulate higher current values without the need of rerunning the stationary current solver each time. Because the originally computed field should be used, a value of 1 is correct. The setting is confirmed with the OK button.

After the source definition is completed, the magnetostatic solver dialog can be opened. Select Solve \(\Rightarrow\) M-Static Solver(\(\Rightarrow\)) and press Start to calculate the magnetic fields for the previously calculated current distribution.

Similar to the stationary current solver, the magnetostatic solver also keeps you informed of its status with a progress bar in the lower left corner of the main window. The newly calculated results are displayed in the navigation tree:

From this calculation, the distribution of the magnetic field is of primary interest. Therefore, select NT \(\Rightarrow\) 2D/3D Results \(\Rightarrow\) H-Field for a visualization of the magnetic field.
Accuracy Considerations

A static field calculation is mainly affected by two sources of numerical inaccuracies:

1. Numerical errors introduced by the iterative linear equation system solver.
2. Inaccuracies arising from the finite mesh resolution.

In the following section, we provide hints on how to handle these errors and how to obtain highly accurate results.

- Numerical errors introduced by the iterative linear equation system solver

CST EM STUDIO™ uses an iterative linear equation system solver to solve the discretized field problem. This means that the iterative solver will stop a calculation when a given accuracy has been reached. For most applications, the accuracy setting of 1e-4 is sufficient. In this case, the accuracy needed to be higher because the subsequent magnetostatic calculation required very accurate current fields.

- Inaccuracies arising from the finite mesh resolution

Inaccuracies arising from the finite mesh resolution are usually more difficult to estimate. The only way to ensure the accuracy of the solution is to increase the mesh resolution and recalculate the results. When the results do not significantly change with increasing mesh density, convergence has been achieved.
The above example used a modified default mesh. The easiest way to test the accuracy of the results is to use fully automatic mesh adaption that can be switched on by checking the Adaptive mesh refinement option in the solver control dialog box Solve → Stationary Current Solver:

After activating the Adaptive mesh refinement tool, you should now start the solver again by pressing the Start button. After the mesh adaption procedure has finished, you can visualize the maximum difference of the loss power error for two subsequent passes by selecting 1D Results → Adaptive Meshing → Error from the navigation tree:

As evident in the above plot, the maximum loss power deviation between the first and second pass is very low, indicating that the calculation with the first mesh already produced quite accurate results.
Getting More Information

Congratulations! You have just completed the stationary current tutorial that should have provided you with a good working knowledge of how to use the stationary current solver in combination with the magnetostatic solver. The following topics have been covered thus far:

1. General modeling considerations, using templates, etc.
2. Model a circuit breaker using the curve line, the curve arc, the trace from curve, the extrude, the brick and the transformation tool.
3. Define boundary and symmetry conditions.
4. Define current ports.
5. Apply changes to the automatically generated mesh.
6. Start the stationary current solver.
7. Visualize the current density fields.
8. Calculate the model’s resistance.
9. Define the current density field as a source for the magnetostatic solver.
10. Start the magnetostatic solver.
11. Visualize the magnetic fields.
12. Ensure accurate and converged results by using the automatic mesh adaption.

You can obtain more information for each particular step from the online help system that can be activated either by pressing the Help button in each dialog box or by pressing the F1 key at any time to obtain context sensitive information.

In some instances we have referred to the Getting Started manual that is also a good source of information for general topics.

In addition to this tutorial, you can find additional stationary current calculation examples in the “Examples” folder in your installation directory. Each of these examples contains a Readme item in the navigation tree that provides more information about the particular device.

And last but not least: Please visit one of the training classes, held regularly at a location near you. Thank you for using CST EM STUDIO™
The Low Frequency Tutorial

Modeling
- Introduction and Model Dimensions
- Geometric Construction Steps
- Further Physical Settings

Hexahedral Solver
- Solver Settings
- Results
- Accuracy Considerations
- Simulation of Material Defect

Tetrahedral Solver
- Solver Settings
- Results
- Simulation without Material Defect

Comparing the Results

Getting More Information
Modeling

Introduction and Model Dimensions

In this tutorial, an eddy current sensor is modeled to simulate non-destructive material testing. You will analyze an eddy current sensor driven by a low frequency coil generating eddy currents in an aluminum probe plate. CST EM STUDIO™ can provide a wide variety of results. This tutorial, however, concentrates solely on the eddy current analysis to detect material defects. The following explanations on modeling and analyzing this device can also be applied to other low frequency problems.

We strongly suggest that you carefully read through the CST EM STUDIO™ Getting Started manual before starting this tutorial.

The structure depicted above consists of the sensor, represented by an excitation current coil embedded in iron material. Below this sensor, the probe plate is given as a lossy aluminum material, allowing the flow of eddy currents. Inside this plate a material defect is modeled as a gap that should be detected by the changing voltage at the coil.

Please note that we will use the same document conventions here as they have been introduced in the Getting Started manual.
Geometric Construction Steps

This tutorial will take you step-by-step through the construction of your model, and relevant screen shots will be provided so that you can double-check your entries along the way.

Select a Template

After starting CST DESIGN ENVIRONMENT™ you will be prompted to either open an existing file or create a new project:

In this dialog box, you should select a CST EM STUDIO™ project and press the OK button. Please note that you can make this selection the default whenever the CST DESIGN ENVIRONMENT™ is started by checking the **Always start with the selected module** option. Once CST EM STUDIO™ is initialized you will see the following window:

![Create a New Project](image)

You are requested to select a template that best fits your current device. Here the “LowFrequency” template should be chosen and confirmed by pressing the OK button.

This template automatically sets the units to mm and kHz, all boundaries to perfect electrically conducting and the background material to normal. Because the background material is now represented by vacuum, the structure can be modeled just as it appears on your desk. Furthermore, the automatic mesh strategy is optimized for low frequency problems, adjusting the ratio limit and the minimum line number for hexahedral meshes and the minimum number of steps and special settings for tetrahedral meshes, respectively.
Set the Units

All desired units are already set by the previously chosen template. You may check these settings in the “Specify Units” dialog box by selecting Solve → Units from the main menu or by clicking on the corresponding icon.

Because no changes are necessary, you can skip this dialog by pressing the OK or Cancel button.

Set the Working Plane’s Properties

The next step will usually be to set the working plane properties to make the drawing plane large enough for your device. These settings can be changed in a dialog box that appears after selecting Edit → Working Plane Properties from the main menu. Because the structure has a maximum extension of 10 mm along a coordinate direction, the working plane Size should be set to 15 (referring to the unit displayed in the status bar that has previously been set to mm):

The Width of the raster, as well as the Snap width, are fine to obtain a reasonably spaced grid. Therefore, please confirm the settings by pressing the OK button.
Draw the Probe Plate

The first construction step for modeling the given device is to define the probe plate. This can easily be achieved by creating a brick made of aluminum material. First, please activate the brick creation mode by choosing Objects ➔ Basic Shapes ➔ Brick from the main menu or by clicking on the corresponding icon.

When you are prompted to define the first point, you can enter the coordinates numerically by pressing the Tab key that will open the following dialog box:

![Enter Point Dialog Box]

In this example, you should enter a plate block that has an extension of 10 mm in each of the transversal directions. The transversal coordinates can thus be described by X = -5 and Y = -5 for the first corner and X = 5 and Y = 5 for the opposite corner, assuming that the brick is modeled symmetrically to the origin. Therefore, please enter the first point’s coordinates X = -5 and Y = -5 in the dialog box as shown above and press the OK button.

Then you can repeat these steps for the second point:

1. Press the Tab key
2. Enter X = 5, Y = 5 in the dialog box and press OK.

Now you will be requested to enter the height of the brick. This can also be specified numerically by pressing the Tab key and entering the Height of 2:

![Enter Height Dialog Box]

Then press the OK button in the “Enter Height” dialog box.

Now the following dialog box will appear and display a summary of your previous input:
Please check all these settings carefully. If you encounter any mistakes, please change the value in the corresponding entry field.

You should now assign a meaningful name to the brick by entering e.g. “Plate” in the \textit{Name} field. Because the brick is the first object you have modeled, you can keep the default settings for the first \textit{Component} (“component1”).

\textbf{Note:} The use of different components allows you to collect several solids into specific groups, independent of their material behavior.

The \textit{Material} setting of the brick has to be changed into the desired probe medium. Because no aluminum material has yet been defined, you should select “[New Material... ]” from the \textit{Material} drop-down list to open the “New Material Parameters” dialog box:
In this dialog box you should define a new Material name (e.g. “Aluminum”) and set the Type to a Normal material. Please choose a color for the material by pressing the Change button.

**Note:** The defined material “Aluminum” will be available inside the current project for the further creation of other solids. However, if you want to save this specific material definition for use in other projects, you may check the button Add to material library. You will have access to this material database by clicking on Load from Material Library in the Materials context menu in the Navigation Tree.

Now we must define the material parameters of the “Aluminum” media. Because only a conductivity has to be set, you may skip the material parameter fields Epsilon and Mu and click on the Conductivity tab to change the dialog page. Please enter an Electric conductivity value of 3.7e7 as shown below:
You can now confirm your settings by pressing the OK button and again reveal the brick creation dialog box:

Here, you can also press the OK button to finally create the plate brick. Your screen should now look as follows (you can press the Space key to zoom the structure to the maximum possible extent):
Model the Gap

The next step is to model the gap inside the probe, representing a material defect. We can do this by creating another brick, as previously shown for the plate. However, first you should move the drawing plane to the top of the plate. This can be easily achieved by activating the face pick tool (Objects Ö Pick Ö Pick Face, □) and double-clicking on the plate’s top face. The face selection should then be visualized as demonstrated in the following picture:

After the face has been selected, you can now align the working coordinate system (WCS) with its plane. Therefore, please either select WCS Ö Align WCS with selected face from the main menu, press the toolbar button □ or simply use the shortcut W. Now the drawing plane will be aligned with the top of the plate (you may switch off the visualization of the global coordinate axes by pressing Ctrl+A, pressing □, or checking Coordinate Axes in the View Ö View Options Ö General dialog):
Please enter again the brick creation mode (Objects ⇒ Basic Shapes ⇒ Brick, ). This time it is suitable to use the pick point facility to easily adjust the brick’s dimensions. Please select Objects ⇒ Pick ⇒ Pick Edge Midpoint from the main menu, click on the corresponding icon or just use the shortcut M. All edges of the created brick are now highlighted in the drawing plane. Please double-click on the lower U edge as marked below:

Please repeat this procedure for the opposite edge in U direction:

1. Select Objects ⇒ Pick ⇒ Pick Edge Midpoint from the main menu
2. Double-click on the upper U edge as marked below
Because both picked points have the same V coordinate, the width of the brick is requested after pressing the Tab key.

Please enter a value of 0.1 for the Width and leave the dialog by pressing the OK button. After you press the Tab key again, you must now enter the height of the brick:

Because the gap should be cut inside the plate, enter a negative value of -1 for the Height and confirm the dialog’s setting by pressing the OK button. In the “Brick” creation dialog box that appears you should define a suitable name for the brick (eg. “Gap”) and check the dimension’s settings:
For the moment, we will model the gap as a part of the plate and also designate it as “Aluminum” material. Therefore, you can just keep the settings of the Component and Material drop-down lists. The brick’s material setting will be changed later in order to compare the solver results with and without an air gap.

After confirming the creation of the brick by pressing the OK button, the following “Shape Intersection” dialog appears, where you should select Insert highlighted shape to cut the gap brick into the plate brick. Note that this operation will preserve the gap-solid whereas the Cut away highlighted shape would remove the gap-solid (which is not intended here in order to model the plate without defect).

Confirm the selection by pressing OK.

Your model should now look like the following figure:
Model the Sensor

Because the sensor is located slightly above the plate, the Local Coordinate System has to be shifted slightly in the W direction. Therefore, please select WCS ⇒ Move Local Coordinates from the main menu or click on the corresponding icon and enter a shift value for DW of 0.1 in the "Move Local Coordinate System" dialog box:

Confirm this setting by pressing the OK button.

The sensor will now be constructed from two cylinders. Therefore, please enter the cylinder creation mode (Objects ⇒ Basic Shapes ⇒ Cylinder). Because the center point of the cylinder is given at the origin of the local coordinate system, you should press the Tab key while holding the Shift key to initialize the "Enter Point" dialog with zeroed values. Accept these settings and again press the Tab key to define the outer radius of the cylinder:
Please enter a value of 3 for the Radius and confirm this setting by clicking the OK button. After pressing the Tab key once more, you can define the Height of the cylinder with a value of 3.8:

![Enter Height Dialog]

Selecting the OK button and skipping the inner radius definition by pressing the Esc key finally opens the cylinder creation dialog, where you can check your settings:

![Cylinder Dialog]

Again, you may choose a suitable Name for the cylinder (eg. “Sensor”). As you can see, the initial setting for the material is the most recently selected “Aluminum” media. Therefore, please select “[New Material...]” from the Material drop-down menu to open the “New Material Parameters” dialog box:
Here you can now define an iron material for the sensor. First, choose a suitable Material name (e.g., "Iron") and set the Type to a Normal material. Additionally, you should enter a value of 100 for the Mue parameter. Then close this dialog by pressing the OK button.

Back in the cylinder creation dialog box, you may finally define a second component by selecting "[New Component]" from the Component drop-down menu:
After you confirm the cylinder’s creation by pressing the OK button, the model should now look similar to the following picture:

Now we will construct a second cylinder in order to hollow out the first cylinder. To achieve this, please again activate the cylinder mode (Objects ⇒ Basic Shapes ⇒ Cylinder, [✓]) and follow these steps to create the second cylinder shape:

1. Press the Tab key while holding the Shift key and confirm the zero center point of the cylinder
2. Press the Tab key and enter the outer Radius of 1.9
3. Press the Tab key and enter the Height of 2.8
4. Press the Tab key and enter the inner Radius of 0.6

After processing these steps you can review your settings in the “Cylinder” creation dialog box:
Because this solid is only used to hollow out the previously defined cylinder, you do not have to consider the Name, Component or Material settings. Just accept the cylinder’s dimension by pressing the OK button. The “Shape Intersection” dialog informs you that “component2:solid1” intersects with “component2:Sensor”.

Please choose Cut away highlighted shape and confirm with OK to create the cavity.

To obtain a better impression of your model it is useful to switch on the cutplane by selecting View ⇒ Cutting Plane from the main menu, clicking on the corresponding icon, or just pressing Shift+C on your keyboard. Your structure should now look similar to the following picture:
Now the iron sensor will be modified by chamfering one of its edges. Choose *Objects ➔ Pick ➔ Pick Edge* from the main menu, click on the corresponding icon or just use the shortcut *E*. Now double-click on the upper circle edge of the sensor as depicted in the following picture:

Now choose *Objects ➔ Chamfer Edges* from the main menu or click on the corresponding icon to open the “Chamfer Edges” dialog box:

Here you can define the value for the *Chamfer width* that will be applied to all previously picked edges. Please enter 0.2 and confirm this setting by pressing the *OK* button. The model should look like this:
Blend Edge

Finally, one more edge of the iron will be modified. This time, however, by blending. Again, choose Objects ➔ Pick ➔ Pick Edge from the main menu, click on the corresponding icon or use the shortcut E. Now double-click on the lower circle edge as shown in the picture below:

Now choose Objects ➔ Blend Edges from the main menu or click on the corresponding icon to open the "Blend Edges" dialog box:
Here you can define the value for the *Radius* that will then be applied to all previously picked edges. Please enter 0.2 and confirm this setting by pressing the *OK* button. Now the structure setup is complete and your final model should look similar to this picture:

**Add Surrounding Space**

In order to suppress some influences from the adjacent boundaries, it is advisable to add some extra space around the complete structure. This can be easily accomplished by defining proper background material properties in the corresponding dialog box that can be opened by selecting *Solve* → *Background Material* from the main menu or by selecting the corresponding icon.
Please activate "Apply in all directions" and enter a value of 2 in the active Distance field. Confirm these settings by pressing the OK button.

Further Physical Settings

- Define the Excitation Coil

The next step is to add the excitation coil to the model. This can be easily done with the help of curve definitions. Therefore, please choose Curves ⇒ New Curve from the main menu or click on the corresponding icon to create a new curve that will be added to the Navigation Tree. Now you have the possibility to define arbitrarily shaped curves. Here we need one circle and one rectangle curve. By choosing Curves ⇒ Circle from the main menu you enter the curve creation mode. As previously used for the cylinder creation, you can initialize the center point by pressing the Tab and Shift key together. Just confirm these settings with the OK button and continue to the “Enter Radius” dialog box by pressing the Tab key:

Please enter here a Radius of 0.9 and leave the dialog by pressing the OK button. You can control your settings in the “Circle” curve creation dialog box.

Leave it without any further changes and again press the OK button.

The created circle curve will be displayed in the mainview as presented in the view below, still showing only half of the structure due to the previously activated cutplane. Immediately after its creation the curve is selected automatically, so that all solids are plotted transparently to offer a better visualization of the curve:
This first curve represents the rotation path for the coil. However, we still need a curve representing the coil’s profile. For this, we must first rotate the local coordinate system by choosing $WCS \Rightarrow \text{Rotate} +90^\circ \text{ around V axis}$ from the main menu or by pressing the Shift and V key simultaneously.

Now the second curve will be created in a similar fashion to the first one, but this time as a rectangular shape. Enter again the curve creation mode by choosing Curves $\Rightarrow$ Rectangle from the main menu ($\square$). Similar to the creation of a brick, you may enter two points defining the dimension of the rectangle curve:

1. Press the Tab key and enter the first point $U = -0.2$ and $V = 0.9$
2. Press the Tab key and enter the second point $U = -2.7$ and $V = 1.7$

Please note that your input settings correspond to the local coordinate system because it is still active. After confirming the second point with the OK button, you can check the rectangle’s dimension in the “Rectangle” curve creation dialog box:

If all these settings are correct, please finally create the curve by pressing OK. Your structure will now look like this:
With the help of the two recently created curves, it is now possible to easily define a current coil. Please choose **Solve ⇒ Current Coil from Curves** from the main menu or click on the corresponding icon 🎨 to enter the coil creation mode. In this mode the profile curve has to be initially selected, whereby each existing curve is highlighted when the mouse cursor is moved over it. Consequently, double-click on the rectangular curve and then on the circle curve when asked to select the profile and path curve, respectively.

Now you can define the excitation settings in the appearing “Define Current Coil From Curves” dialog box:

![Define Current Coil From Curves](image)

To apply a total current flow of 100 A in the cross-section of the coil, please enter a **Current** value of 0.1 A and a **Number of turns** of 1000. Furthermore, select "Vacuum" from the **Material** drop-down menu for the coil embedding (insulator) material.

After confirming these settings you can double-check your model with the picture below (in order to obtain a similar view, please select the “coil1” item of the “Coil” folder in the **Navigation Tree** or just double-click on the coil in the drawing plane):
For the next step, the local coordinate system is no longer needed, so you may switch it off by choosing WCS $\rightarrow$ Local Coordinate System from the main menu or click on the corresponding icon $\mathcal{L}$. Instead, switch on the visualization of the global coordinate axes again by clicking $\mathcal{A}$, selecting Coordinate axes from View $\rightarrow$ View Options $\rightarrow$ General dialog page or just press Ctrl+A. Furthermore, you may also deactivate the cutplane by pressing Shift+C or by selecting View $\rightarrow$ Cutting Plane from the main menu ($\mathfrak{D}$) and checking No cutplane before pressing the OK button.

Define Boundary and Symmetry Conditions

Electric boundary conditions has been set by the "LowFrequency" template. You do not need to change this default setting.

Note that this setting models a situation when the entire structure (including the background box material) is embedded into a perfectly conducting housing. Of course, keeping in mind that the structure is surrounded by open space, the artificial truncation of the computational domain introduces an additional modeling error. In order to reduce this error, a larger background material box can be defined. Nevertheless, for the tutorial, you should not use a substantially larger box, as doing so would elongate the computation time. However, you should always be aware of the additional truncation error if you aim to model open space problems. For such situations it is advisable to compute the same problem twice using different sizes for the background material box to check if the result of interest will stay unchanged when the box is enlarged.

If you have defined a problem in CST EM STUDIO™ you should always ask yourself the following question: "Can I take advantage of symmetries in my model?"

Remember that a field-solution will be symmetric with respect to a coordinate plane if
- the structure (geometry),
- the defined sources,
- and the defined boundary conditions

are all symmetric with respect to this coordinate plane. If this happens, you can exploit this a priori knowledge to considerably reduce the computational time by defining symmetry planes. Each symmetry plane you define will reduce the problem size by a factor of two.
Here you can activate two planes, reducing the problem size by a factor of four: The model structure is symmetric with respect to the YZ as well as the XZ plane. Moreover, the magnetic field generated by the coil has no normal component at these planes and all boundary conditions are electric. Therefore, the field solution is unaffected if a purely tangential magnetic field is explicitly enforced at these symmetry planes by selecting electric symmetry conditions.

For this purpose, open the “Boundary Condition” dialog box by choosing Solve ➔ Boundary Condition from the main menu or click on the corresponding icon and step to the “Symmetry Planes” tab:

![Boundary Conditions dialog box](image)

Now select the “electric (Et = 0)” option from the corresponding drop-down menus. The changes made are visualized simultaneously in the drawing plane:

![Boundary conditions settings](image)

After visually checking the symmetry settings you confirm the settings by pressing the OK button in the “Boundary Condition” dialog box.
You can find a similar example for the application of symmetry planes in the CST EM STUDIO™ Getting Started manual.

Define the Frequency

Now the calculation frequency must be defined. For this purpose, please choose Solve ⇒ Calculation Frequency from the main menu or click on the corresponding icon to open the “Define Calculation Frequency” dialog box:

Here you have the possibility of entering several frequency points for which calculations should be performed. However, in this case it is sufficient to determine only one Frequency sample at 12 kHz (corresponding to the current frequency unit displayed in the status bar). After you have entered the value press the OK button.

Hexahedral Solver

In a first simulation run, the low frequency solver on hexahedral grids is applied. Because this is the default mesh type, you do not need to change anything here. In a later step a tetrahedral mesh will be used for this structure. Now let’s focus on the hexahedral mesh generation options.

Solver Settings

Mesh Adjustment

It is important that the skin effect is adequately represented by the numerical simulation. It is recommended to have at least two mesh lines in the first skin depth. At 12 kHz the skin depth in the defined aluminum material is approximately 0.8 mm (you can conveniently compute the skin depth using a predefined macro via Macros ⇒ Calculate ⇒ Calculate Skin Depth and Surface Roughness). Consequently, a reasonable mesh size for the plate is 0.4 mm.

Now double-click on the plate-solid in the main view and select Edit ⇒ Mesh Properties. Alternatively, you can click with the right mouse button on the Components ⇒ component1 ⇒ Plate item from the Navigation Tree to open its context menu and select the “Mesh Properties...” option as shown in the next figure.
Then the following dialog box will open, where you can specify special mesh settings assigned only to the selected “component1:Plate” solid:

Enter 0.4 for the *Maximum mesh step width* in z direction, which is the direction perpendicular to the plate surface, and press the *OK* button.
For the extremely small gap, modeled to represent a material defect later on, it is advisable to refine the mesh around this detail to ensure a sufficient resolution of the field effects there. So, please double-click on the gap-solid in the main view and select Edit \(\rightarrow\) Mesh Properties to specify special mesh settings assigned only to the selected "component1:Gap" solid:

To achieve a better mesh resolution inside and around the gap, you can adjust the settings of the Mesh refinement. Please activate the check button Use local edge refinement factor and enter 5 into the enabled field. This applies a good refinement considering the transversal mesh lines at all edges of the gap solid. However, it is also advisable to refine the solid over its complete volume, so please also activate the option Use local volume refinement factor and define a value of 2.

**Note:** The hexahedral mesh refinement settings offer the possibility of refining the mesh inside and around a specific solid and will be considered with respect to the global mesh parameters.

Moreover, set a Maximum mesh step width value in the \(Dx\) field of 0.4. This ensures that the skin depth is adequately resolved in this solid, independently of the other mesh parameters.

Confirm the settings by pressing the OK button. In order to control your changes, you may observe the current mesh distribution by choosing Mesh \(\rightarrow\) Mesh View from the main menu or by clicking on the corresponding icon.
Deactivate the mesh view afterwards by again selecting *Mesh* ⇒ *Mesh View* from the main menu (keyboard shortcut).

☐ Define the Solver’s Parameters and Start the Calculation

The low frequency solver's parameters are specified in the solver control dialog box that can be opened by selecting *Solve* ⇒ *LF-Solver* from the main menu or pressing the corresponding icon in the toolbar:

Here you have the option to adjust the desired *Accuracy* setting. However, for this model the value of 1e-4 is adequate, so you can run the simulation by pressing the *Start* button.
A progress bar will now appear in the status bar that will keep you informed of the solver’s progress. According to the currently performed operation, an information text will be displayed next to the progress bar.

![Progress Bar Example]

This progress bar will disappear when the solver has successfully finished.

**Note:** The electric and magnetic fields, as well as the magnetic energy density, are stored for every calculation frequency for visualization purposes. Additionally, in cases of lossy materials, the eddy current distribution, the total current distribution (sum of source and eddy current) and the loss density are also monitored.

**Results**

Congratulations, you have simulated the eddy current sensor with the hexahedral solver! Let’s review the results. Keep in mind that the first simulation was performed without any material defect in the probe plate.

You will notice that some new entries have appeared in the *2D/3D Results* folder in the *Navigation Tree*:

![Navigation Tree Screenshot]

Because this tutorial focuses on the eddy current produced inside the probe plate, please click on the *Eddy-Current [12]* folder to visualize the three dimensional arrow plot (you may have to step the phase of the fields to 90° just by pressing the right cursor key (→) several times after clicking once in the main view). Clearly, the concentration of the eddy currents near the plate surface due to the skin effect can be observed.
Any material defect in the probe will usually be detected by measuring the change of voltage induced inside the coil. To check the voltage value, have a look by double-clicking on the \textit{Coil voltages} text info icon in the \textit{Navigation Tree}:

\begin{verbatim}
Coil Voltages at frequency [1.200000e+004]:
-------------------------------------------------------------
coil1:  4.304432e+000 + i 6.133052e+001 V (rms)
\end{verbatim}
Accuracy Considerations

A low frequency field calculation is mainly affected by two sources of numerical inaccuracies:

1. Numerical errors introduced by the linear equation system solver.
2. Numerical errors arising from the finite mesh resolution.

In the following section, we provide hints on minimizing these errors and obtaining highly accurate results.

☐ Numerical Errors Introduced by the Linear Equation System Solver

CST EM STUDIO™ uses an iterative linear equation system solver to solve the discretized field problem. The iterative solver will stop a calculation when a given accuracy has been reached. Generally, the accuracy setting of 1e-4 is sufficient for most calculations. In some cases, however, you should consider increasing the solver accuracy by setting a smaller value, particularly if the solver gives you a warning that some results are inaccurate.

Computing twice with different solver accuracies while watching the value of interest (e.g. the power losses) is a simple check to ensure a sufficiently high solver accuracy.

☐ Numerical Errors Arising from the Finite Mesh Resolution (Discretization Error)

Inaccuracies arising from the finite mesh resolution are usually more difficult to control. One possibility of ensuring the solution accuracy is to compare the results of a hexahedral mesh solver-run with the results of a tetrahedral solver-run. We will do this later on.

Another way to ensure the accuracy of the solution is to increase the mesh resolution by a reasonable amount and recalculate the results. When the results no longer significantly change with increasing mesh density, then convergence has been achieved.

In the example above you have used a modified default mesh. The easiest way to test the accuracy of the results is to use fully automatic mesh adaption that can be switched on by checking the Adaptive mesh refinement option in the solver control dialog box (Solve ⇒ LF-Solver, Adaptive mesh refinement):
After activating the adaptive mesh refinement tool, you should now start the solver again by pressing the Start button.

You will then be asked whether the current results should be deleted, saved in a result cache or stored as a new project file:

In this case, the results can be deleted and you may accept the dialog by pressing the OK button.

Now several simulation passes are performed until the change in the energy is less than the desired accuracy. Finally, after a couple of minutes, a dialog box will appear, informing you that the desired accuracy limit (1% by default) could be met by the adaptive mesh refinement. Because the expert system’s settings have now been adjusted such that this accuracy is achieved, you should switch off the adaptation procedure for subsequent calculations (e.g. parameter sweeps or optimizations) by pressing the Yes button.

The major advantage of this expert system based mesh refinement procedure over traditional adaptive schemes is that the mesh adaptation needs to be carried out only once for each device to determine the optimum settings for the expert system. Afterwards, there is no need for time-consuming mesh adaptation cycles during parameter sweeps or optimization.
You already know at this stage that the change in the computed energy value during the last adaptive runs is less than 1%. Now let's examine the change in the Ohmic losses that define the resistive part of the coil voltage. You can visualize the change of this value for two subsequent passes by selecting 1D Results $\rightarrow$ Adaptive Meshing $\rightarrow$ Total Losses from the Navigation Tree:

As you can see, the change of the losses is about 2.6%.

Please now observe the calculated coil voltage by clicking on the Coil voltages text info icon in the Navigation Tree:

Coil Voltages at frequency [1.200000e+004]:
--------------------------------------------
coill: 4.418262e+000 + i 6.088120e+001 V (rms)

You can observe that the difference of the magnitude of induced voltage between our first computation and the adaptive run is approximately 1%. This change corresponds to the change in the energy that is caused by the inductive part of the coil voltage dominating. In the section 'Comparing the Results' we will have a more detailed look at this point.

Simulation of Material Defect

To this point, we have calculated the voltage results for a probe without defects. Now this value will be compared to the case when a material defect is added to the plate. Here we will take advantage of the expert system based mesh adaption since we do not have to perform the adaption paths again. We now proceed with the current refined mesh settings.
To model the material defect, the “Gap” solid, currently assigned to “Aluminum” material, should now be changed to “Vacuum” material. Therefore, please double-click on the gap-solid in the main view and select Edit ⇒ Change Material…

Alternatively, you can open the context menu of the “Gap” solid by clicking with the right mouse button on the Components ⇒ component1 ⇒ Gap item and selecting the Change Material option inside the context menu (see the following figure).

The following dialog box will open, where you can select “Vacuum” from the Material drop-down menu:

After confirming this modification you will be asked whether the current results should be deleted, saved in a result cache or stored as a new project file:
Again, the results can be deleted and you may accept the dialog by pressing the OK button. Now the gap inside the aluminum plate is filled with vacuum material as can be seen by selecting again the Components $\Rightarrow$ component1 $\Rightarrow$ Gap item in the Navigation Tree:

Please restart the calculation as before by opening the solver control dialog box (Solve $\Rightarrow$ LF-Solver, $\Rightarrow$) and pressing the Start button. After the simulation has finished you can again observe the calculated eddy currents inside the probe (you have the possibility to scale and modify the plotted arrows inside the “3D Vector Plot” dialog box, that opens after double-clicking on the mainview plane). As before, you may have to step the phase of the fields to 90° by pressing the right cursor key (→) several times after clicking once in the main view.
Obviously the flow of the eddy current inside the probe is strongly affected by the vacuum gap. This should also be observable by looking at the induced coil's voltage. Therefore, please click again on the *Coil voltages* info text item:

Coil Voltages at frequency $[1.200000e+004]$:
--------------------------------------------
coil1: $3.545700e+000 + i 6.236208e+001$ V (rms)

There is a difference of about 1.42 V between the absolute voltage values with and without the gap, enabling the detection of the material defect.
Tetrahedral Solver

In this sub-section, the tetrahedral low-frequency solver is applied to the same problem and the results are compared to the results of the hexahedral solver.

Solver Settings

- **Mesh Adjustment**

  First, switch from the hexahedral to the tetrahedral mesh type by selecting *Mesh* → *Global Mesh Properties*… or by clicking on the button.

![Mesh Properties dialog box](image)

For this purpose, select "Tetrahedral" from the *Mesh type* drop-down list in the global *Mesh Properties* dialog. To get a reasonable overall mesh resolution of the problem, set the *Min. number of steps* to 30. Do not press *OK* at this stage.

Along the blended edges of the sensor core, one expects a concentration of the magnetic field. In order to appropriately resolve this phenomenon it is necessary to resolve the curvature of the blends. Furthermore, the curved coil geometry should be adequately taken into account. To achieve this you may change the default curvature refinement settings by clicking on the *Special* button. The following dialog box will open:
In the **Special Mesh Properties** dialog, set the **Curvature refinement ratio** value to 0.02 and the **Max. number of steps from curvature ref.** to 200.

The first value defines an upper bound for the deviation of the mesh geometry from the original curved geometry. More precisely, the mesh size is defined such that the ratio \(d/h\) (see following figure) is less than the given value everywhere. Reasonable values for usual applications are in the range from 0.01 to 0.05.

The second value is necessary to prevent extremely fine meshes at geometric singularities. It defines how much smaller the mesh size defined by the curvature refinement ratio is allowed to be compared to the original mesh size of the shape. Usual values are in the range of 50 to 500.

After this short introduction to the curvature refinement for tetrahedral meshes, return to the global **Mesh Properties** dialog by pressing the **OK** button of the **Special Mesh Properties** dialog. Finally, press the **OK** button of the global **Mesh Properties** dialog.

As in the application of the hexahedral solver, it is important that the mesh adequately resolve the skin depth in the aluminum plate. To ensure this, set local mesh densities: Double-click on the plate-solid in the main view and select **Edit → Mesh Properties**... to open the following dialog box, where you can specify special mesh settings assigned only to the selected “component1:Plate” solid.
Set the Max. step width value to 0.4 and press the OK button.

In the same manner, set a local mesh density for the gap: Double-click on the gap-solid in the main view and select Edit ➔ Mesh Properties… to open the following dialog box:
Here you may select an even smaller value. A good choice that leads to an almost isotropic mesh in the gap-solid is the gap-width. Therefore, set the Max. step width value to 0.1 and press the OK button.

- Define the Solver’s Parameters and Start the Calculation

Now all mesh adjustments have been performed and you can start the tetrahedral low frequency solver: Select \textit{Solve} \textit{$\Rightarrow$ LF-Solver} from the main menu or press the corresponding icon \textit{!} in the toolbar. The low frequency solver dialog will open.

If not already pre-selected, set the \textit{Mesh Type} to "Tetrahedral". It is not necessary to modify the default \textit{Accuracy} value of 1e-4. Now press the \textit{Start} button.
The solver will first start the tetrahedral mesh generator. Note that this only applies if the tetrahedral mesh has not already been generated before via Mesh $\Rightarrow$ Update. You will see a progress bar displaying the status of the mesh generation.

| Generating Tetrahedral Mesh: | Volume meshing (pass 3) |

**Note:** The generation of a tetrahedral mesh is usually much more time-consuming than the generation of an hexahedral mesh in CST EM STUDIO™ because the tetrahedral mesh resolves the geometry explicitly whereas a hexahedral mesh does not. Remember that the hexahedral solver resolves the geometry implicitly using the Perfect Boundary Approximation® (PBA) technique.

Then, the solver itself will be started. As for the hexahedral solver, you will receive information on the progress of the solver and the currently performed operation in the status bar. Usually the most time consuming part of the solver run is the solution of the linear system of equations.

| Low Frequency Solver: | Linear equation solver is running. |

The progress bar will disappear when the solver has successfully finished.

**Results**

Congratulations, you have simulated the eddy current sensor with the tetrahedral solver! Initially, you may want to inspect the mesh by selecting Mesh $\Rightarrow$ Mesh View from the main menu or clicking on the corresponding icon  

![Image of the mesh]

You will recognize that the mesh around the gap and at the curved sensor edges is very fine and that the mesh density in the plate is higher than in the sensor, as expected.

Let's examine the results. Remember that the gap-solid's material is still vacuum, modeling the material defect.
You will see that the same entries have appeared in the 2D/3D Results folder in the Navigation Tree as before in the hexahedral solver run:

Again, click on the Eddy-Current [12] folder to visualize the three-dimensional arrow plot and remember that you may have to step the phase of the fields to 90° by pressing the right cursor key (→) several times after clicking once in the main view:

To check the voltage value, double-click on the Coil voltages text info icon in the Navigation Tree:

Coil voltages at frequency [  12.000 kHz]:
----------------------------------------------
coill    : 3.642732e+000 + i 5.988392e+001 V (rms)

Comparing this result with the computation using the hexahedral solver you can observe a difference of less than 3% for the real part and about 4% for the imaginary part of the coil voltage.
Simulation without Material Defect

Let’s return to the initial configuration without the material defect. The “Gap” solid, currently assigned to “Vacuum” material, should now be changed back to “Aluminum” material: Double-click on the gap-solid in the main-view and select Edit ⇒ Change Material… in the main menu to open the following dialog box, where you can select “Aluminum” from the Material drop-down menu:

After confirming this modification by pressing the OK button you will be asked if the current results should be deleted, saved in a result cache or stored as a new project file:

Again, the results can be deleted and you may accept the dialog by pressing the OK button. Now the gap inside the aluminum plate is filled with aluminum material, as well.

Please restart the tetrahedral solver as before by opening the solver control dialog box (Solve ⇒ LF-Solver, ) and pressing the Start button.

After the simulation has finished, examine again the computed eddy currents inside the probe by clicking on the corresponding entry in the Navigation Tree: 2D/3D Results ⇒ Eddy-Current [12]. Remember that you may have to step the phase of the fields to 90° by pressing the right cursor key (→) several times after clicking once in the main view.
In order to compare the computed coil voltage to the coil voltage of the previous solver run including the material defect, click again on the Coil voltages info text item:

Coil voltages at frequency [12.000 kHz]:

<table>
<thead>
<tr>
<th>Coil</th>
<th>Voltage</th>
</tr>
</thead>
<tbody>
<tr>
<td>coil1</td>
<td>4.493624e+000 + i 5.837238e+001</td>
</tr>
</tbody>
</table>

There is a difference of about 1.45 V between the absolute voltage values of the two tetrahedral solver runs with and without the gap.

## Comparing the Results

Before we compare the results of the hexahedral and tetrahedral solvers, let us review the meaning of the real and imaginary part of the computed coil voltage.

Consider the well-known formula

\[ U_{rms} \cdot I_{rms} = P_{loss} + i 2 \omega W_{mag} , \]

where \( U_{rms} \) and \( I_{rms} \) denote the RMS values of the coil-voltage and the coil-current, respectively, \( \omega \) denotes the angular frequency, \( W_{mag} \) denotes the mean value of the magnetic energy and \( P_{loss} \) denotes the mean value of the Ohmic losses.

Hence, one gets the following expression for the coil-voltage:

\[ U_{rms} = (P_{loss} + i 2 \omega W_{mag}) / I_{rms} . \]
Because the coil-current is real-valued in the example, the real part of the coil voltage is proportional to the Ohmic losses in the plate and the imaginary part is proportional to the magnetic energy stored in the system.

Now let us compare the results: The computed voltage drop due to the material defect is very similar for both solvers (1.45 V for the tetrahedral, 1.42 V for the hexahedral solver). Similarly, the phase shifts due to the material defect are in good agreement (0.92° for the tetrahedral and 0.90° for the hexahedral solver).

However, looking at the voltage values themselves again, you can observe some more noticeable differences between the simulations of hexahedral and tetrahedral solver, especially for the (dominating) imaginary part of the coil voltage.

Consequently, with the current mesh-resolution the magnetic energy is not computed accurately enough to yield precise imaginary parts of the voltages. In particular, the default accuracy in the adaptive computation is not high enough for this case -- one has to compute this example using even finer meshes to get much less than 1% error in the energy. This has not been done in this tutorial to keep the single solver runs short and demonstrate how possible differences can be interpreted.

Finally, note that for extremely accurate computations of models that include curved coils, the tetrahedral solver is usually more suitable than the hexahedral solver because the current distribution in the coil can be resolved more easily, leading to a faster convergence with respect to the mesh density.

**Getting More Information**

Congratulations! You have just completed the tutorial which should have provided you with a good working knowledge on how to use the low frequency solver. The following topics have been covered:

1. General modeling considerations, using templates, etc.
2. Model a sensor including probe plate by using the brick and cylinder creation modes.
3. Define an excitation coil from previously defined curves.
4. Define symmetry conditions.
5. Apply changes to the automatically generated hexahedral mesh.
6. Start the hexahedral low frequency solver.
7. Visualize the eddy current fields.
8. Use the automatic mesh adaptation to get information on the magnitude of the accuracy of the results.
9. Apply changes to the automatically generated tetrahedral mesh.
10. Start the tetrahedral low frequency solver.
11. Compare and interpret the results.

You can obtain more information for each particular step from the online help system that can be activated either by pressing the Help button in each dialog box or by pressing the F1 key at any time to obtain context sensitive information.

In some instances we have referred to the *Getting Started* manual that is also a good source of information for general topics.

In addition to this tutorial you can find more low frequency problems in the “examples” folder in your installation directory. Each of these examples contains a Readme item in
the Navigation Tree that will provide you with more information about the particular device.

And last but not least: Please also visit one of the training classes, held regularly at a location near you. Thank you for using CST EM STUDIO™!