
Lab 4: Root Locus For Controller Design 
 
Overview 
 
 In this Lab you will explore the use of the root locus technique in designing controllers. 
The root locus indicates the possible location of the closed loop poles of a system as a 
parameter (usually the gain k) varies from small to large values. Often we implement 
controllers/compensators to put the dominant poles of a system in a location that will 
produce a more desirable response. This assignment is to be done with Matlab's sisotool. 
 
 Some things to keep in mind about the root locus: 

• The only possible closed loop poles are on the root locus. 
• The root locus starts (k = 0) on poles and ends ( k = ∞ ) on zeros. 
• If you click on the root locus plot, it gives you the value of gain k and the location 

of the closed loop poles on that branch for that value of k. It does not tell you all 
of the closed loop pole locations if there is more than one branch. 

• All of the poles and zeros you add to the system should be in the left half plane. 
 
 
Memo Your (brief) memo for this lab should summarize what you think are the benefits 
and drawbacks of each of the basic controller types. For each of the three systems 
analyzed you need to include as attachments your plots of the step response 
and the values of , , and  for each controller. You will also need to include root 
locus plots for some of the systems (only if asked for!) Finally, is the control effort for the 
I and PI controllers larger at the initial time, or later, near steady state? 
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Controller Configuration 
 
In this lab we will be assuming a unity feedback controller of the following form, where 
C(s) is the controller and G(s) is the plant (this is the notation sisotool uses). 
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Common Controller Types 
 
Proportional (P) Controller: ( ) pC s k k= =  
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Proportional+Derivative (PD) Controller: ( ) ( )p dC s k k s k s z= + = +  
 
Proportional+Integral+Derivative (PID) Controller:  
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For the PID controller, we can have either two complex conjugate zeros or two real zeros. 
 

In sisotool, you will see the transfer functions form of the controllers. To determine 
the parameters , , and  you need to equate powers of s of the transfer 
functions with the forms above. It is  easies t if you use the zero/pole/gain format for 
the compensators. To do this click on  Edit → SISO Tool Preferences → Options 
and click on zero/pole/gain. 
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Note if  the system is stable, the I,  PI, and  PID controllers will produce a steady state 
error of zero unless the system being controlled has a zero at the origin which would 
cancel with the controllers pole at the origin. 
 
 
 
 
 
 
 



Introduction to sisotool 
 
Getting Started 
 

• Enter the transfer function for the plant, G(s), in your workspace. 
• Type sisotool in the command window 
• Click  close when the help window comes up 
• Click on  vVew, the Design Plots Configuration, and turn off all plots except the 

Root Locus plot 
 
Loading the Transfer Function 
 

• Click on file → import. 
• We will usually be assigning G(s) to block G (the plant), so type your transfer 

function name next to G and then enter. You must hit enter or nothing will 
happen. 

• Once you hit enter, you should be able to click on the OK at the bottom of the 
window. The window will then vanish. 

• Once the transfer function has been entered, the root locus is displayed. Make 
sure the poles and zeros of your plant are where you think they should be. 

 
 
Generating the Step Response 
 

• Click on Analysis →  Response to Step Command 
• You will probably have two curves on your step response plot. To just get the 

output, type Analysis → Other Loop Responses. If  you only want the output, 
then only r to y is checked, and then click OK. However, sometimes you will also 
want the r to u output, since it shows the control effort for P, I, and PI controllers. 

• You can move the location of the pole in the root locus plot by putting the cursor 
over the pink button and  holding the left button down as you move the pole 
locations. You should note that the step response changes as the pole locations 
change. 

• The bottom of the root locus window will show you the closed loop poles 
corresponding to the cursor location. However, if you need all of the closed loop 
poles you have to look at all of the branches. 

 
 
 
 
  



 
Entering a Compensator (Controller) 
 

• Type Designs →Edit Compensator 
• Right click in the Dynamics window to enter real poles and zeros. You will be 

able to changes these values very easily later. 
• You can either edit the pole/zero locations in this window, or by grabbing the 

poles and zeros in the root locus plot and moving them. However, sometimes you 
just have to go back to this window. 

• Look at the form of C to be sure it's what you intended, and then look at the root 
locus with the compensator. 

• You can again see how the step response changes with the compensator by 
moving the locations of the poles (grab the pink dot and slide it). 

• You can also change the location of the pole and zeros of the compensator by 
grabbing them and sliding them. Be careful not to change the poles and zeros of 
the plant though! 

 
Adding Constraints 

• Right Click on the Root  Locus plot, and choose Design Constraints then either 
New to add new constraints, or  Edit to edit existing constraints. 

• At this point you have a choice of various types of constraints. 
 
 
Printing/Saving the Figures: 
 
To save a figure sisotool has created, click File → Print to Figure 
 
 
 
Odds and Ends : 
 

You may want to fix the axes. To do this, 
 

• Right click on the Root Locus Plot 
• Choose Properties 
• Choose Limits 
• Set the limits and turn the Auto Scale off 

 
You may also want to put on a grid, as another method of checking your answers. To 
do this, right click on the Root Locus plot,  then choose Grid 

 
It is easiest if you use the zero/pole/gain format for the compensators. To do this 
click on  Edit → SISO Tool Preferences → Options and click on zero/pole/gain. 

 
 



Part A 
 
Let's assume the plant we are trying to control has the transfer function 
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This is second order system with two real poles, located at -5 and -6. Our general goal 
will be to speed up the response of the system and produce a system with a steady state 
error for a unit step input of 0.1 or less, a percent overshoot of 10% or less, and a settling 
time of less than 1 second.  To keep things reasonable, assume we want for all 
designs, however the values of , , and may individually be larger than 10.  . You 
must write down the values of , , and  for each of the following designs and 
include these in the captions for the figures. 
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You need to  use the zero/pole/gain format for the compensators. To do this click on 
Edit → SISO Tool Preferences → Options and click on zero/pole/gain. 

 
Step 1: Entering the Constraints 
 
Enter the percent overshoot and settling time constraints into sisotool. Remember, these 
are only guidelines. 
 
Step 2: Proportional (P) Control 
 
 a) Determine the root locus of this system with proportional gain. (This is the default for 
sisotool.) 
b) Look at the step response as the gain increases.  You should notice a few things: 
 

• as k increases, the imaginary part of the closed loop poles increases, thus the PO 
(Percent Overshoot) increases 

• as k increases, the steady state error decreases 
• since the real part of the pole does not change once k is greater than about 0.008, 

the settling time remains fairly constant at about 0.8 seconds. 
• there is no value of k for which the system is unstable 

 
Do as well as you can to meet both constraints then save the root locus and the 
corresponding step response figure for your memo. Be sure to record the value of k you 
used! 
 
 



Step 3: Integral (I) Control 
 
 a) Look at the root locus for  the system with an integral controller. You will need to 
click on  Designs → Edit  Compensators. Then you need to right click in the left box 
and place the pole at zero. Note that once you have placed the compensator poles and 
zeros, you can click and drag them. However, for an integral controller the pole is 
always at zero. 
 
b) For what value of k will the system become unstable? 
 
c) Try and find a value of k that gives fast response with little overshoot, with a settling 
time less than or equal to 2 seconds. 
 
d)  Is steady state error zero? Is the system response very fast? Can you meet the (1 
second) settling time requirement? 
 
Save the step response plot (and the k value) for your memo. 
 
Step 4: Proportional+Derivative (PD) Control 
 
 a) Look at the root locus for the system with a PD controller. You will need to click on 
Designs →Edit Compensators. You need to delete the pole from the I controller and 
add a real zero. Note that for this type of design the zero can be moved. 
 
b) Find a controller that produces a settling time of 0.1 seconds (or less) and a steady 
state error of 0.1 or less. (Remember 10k ≤ ). Save the step response values of  and  
that produced it for your memo. 
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Step 5: Proportional+Integral (PI) Control 
 
 a) Look at the root locus for the system with a PI controller. You will need to click on 
Designs →Edit Compensators. Then you need to add real pole at the origin. For a PI 
controller, one pole is always fixed at the origin. The zero of the compensator can move, 
but the pole cannot. 
 
b) Look at the root locus and step response for the system with the zero of the PI 
controller between 0 and -5. Find a controller that produces a settling time of less than 0.8 
seconds, a percent overshoot less than 2%, and a steady state error of 0. Save the step 
response, root locus plot, and the values of  and  that produced the step response for 
your memo. Are all of your poles in the ``acceptable'' regions? Hint: you may want to 
scale the axes. 
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Step 6: Proportional+Integral+Derivative (PID) Control 
 
a) Place the zeros of the controller at 7 7 j− ±  and plot the root locus. 
 
b) Find a value of k (on this root locus) so that the step response of the system has a PO 
less than 10% and a settling time less than 0.5 seconds. Save the step response, the root 
locus (zoom in near the origin so you can see something), and the values of , , and 

 that produced the step response for your memo. Are your poles and zero's within the 
``acceptable'' region? 

pk ik

dk

 
 c) Keeping the real part of the zero at -7, reduce the imaginary part of the zero as much 
as possible while keeping the same basic shape of the root locus. At some point, the root 
locus will take on a very different shape. Find a value of k (on the root locus) so that the 
step response of the system has a PO less than 2%, a settling time less than 0.02 seconds, 
and a steady state error of less than 0.01. Save the step response, the root locus (zoom in 
near the origin so you can see something) and the values of , , and  that produced 
the step response for your memo (Remember  
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10k ≤ ) Are your poles and zero's within 

the ``acceptable'' region? 
 
 
d) Assume we want a PID controller with real zeros at -7 and -8. Determine the root locus 
of this system. Find a value of k so that the PO is less than 2% and the settling time is less 
than 0.02 seconds. Save the step response, the root locus (zoom in near the origin so you 
can see something) and the values of , , and  that produced the step response for 
your memo (Remember  ) Are your poles and zero's within the ``acceptable'' 
region? 
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Part B 
 
Let's assume the plant has the transfer function 
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This is a model I obtained from one of the rectilinear systems in the controls lab. 
 

You need to  use the zero/pole/gain format for the compensators. To do this click on 
Edit → SISO Tool Preferences → Options and click on zero/pole/gain. 

 
You should try and meet the following constraints 
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You should do your best to meet each one of these, but in any event you must have 
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In addition, for the I and PI controllers you must have| ( ) | 0.45u t < . Your step response 
graphs must also show the control effort for these two types of controllers! 
 
 
You need to try to meet these design constraints for a 
 

• I controller (hard to meet settling time, probably need 4secsT ≈ ) 
• PD controller  
• PI controller (hard to meet settling time, probably need 3.5secsT ≈ ) 
• PID controller with real zeros 
• PID controller with complex conjugate zeros 

 
For each one of these you need to save you step response and the values of  , , and 

 that produced it for your memo. 
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Part C 
 
Let's assume the plant has the transfer function 
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This is a model I obtained from one of the torsional systems in the controls lab. 
 

You need to  use the zero/pole/gain format for the compensators. To do this click on 
Edit → SISO Tool Preferences → Options and click on zero/pole/gain. 

 
You should try and meet the following constraints 
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You should do your best to meet each one of these, but in any event you must have 
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In addition, for the I and PI controllers you must have | ( ) | 0.39u t < . Your step response 
graphs must also show the control effort for these two types of controllers! 
 
 
You need to try to meet these design constraints for a 
 

• I controller (hard to meet settling time, probably need 4secsT ≈ ) 
• PD controller (probably won't work, do the best you can) 
• PI controller (really hard to meet settling time, probably need ) 10secsT ≈
• PID controller with real zeros 
• PID controller with complex conjugate zeros 

 
For each one of these you need to save you step response and the values of  , , and 

 that produced it for your memo. 
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